Problem with FC0012 Tuner & librtlsdr0

Main forum to discuss RTL-SDR related topics.
Post Reply
Raff94
Posts: 1
Joined: Sat Jun 24, 2017 9:50 am

Problem with FC0012 Tuner & librtlsdr0

Post by Raff94 » Sat Jun 24, 2017 10:02 am

Hello,

I have a problem with my Tuner FC0012:

When I run a typical command:

Code: Select all

Pi @ raspberrypi: ~ $ rtl_fm -M fm -f 446M: 446.1M: 6.25k -s 12k -g 50 -l 10 | Aplay -r 12k -f S16_LE
Found 1 device (s):
  0: Realtek, RTL2838UHIDIR, SN: 00000001

Using device 0: Generic RTL2832U OEM
No supported tuner found
Enabled direct sampling mode, input 1
Tuner gain set to 0.00 dB.
Tuned to 446252000 Hz.
Oversampling input by: 84x.
Oversampling output by: 1x.
Buffer size: 8.13ms
Exact sample rate is: 1008000.009613 Hz
Sampling at 1008000 S / s.
Output at 12000 Hz.
After installing librtlsdr0 with this:

Code: Select all

 sudo apt-get install librtlsdr0 
So when I restart my first command it detects my tuner but with an error:

Code: Select all

Pi @ raspberrypi: ~ $ rtl_fm -M fm -f 446M: 446.1M: 6.25k -s 12k -g 50 -l 10 | Aplay -r 12k -f S16_LE
Found 1 device (s):
  0: Realtek, RTL2838UHIDIR, SN: 00000001

Using device 0: Generic RTL2832U OEM
Found Fitipower FC0012 tuner
Tuner gain set to 19.20 dB.
Rtl_fm: symbol lookup error: rtl_fm: undefined symbol: rtlsdr_set_bias_tee
Aplay: playback: 2715: playback error
So I uninstalled librtlsdr0 with:

Code: Select all

 sudo apt-get remove librtlsdr0 
And for a third time the spear:

Code: Select all

Pi @ raspberrypi: ~ $ rtl_fm -M fm -f 446M: 446.1M: 6.25k -s 12k -g 50 -l 10 | Aplay -r 12k -f S16_LE
Found 1 device (s):
  0: Realtek, RTL2838UHIDIR, SN: 00000001

Using device 0: Generic RTL2832U OEM
Found Fitipower FC0012 tuner
Tuner gain set to 19.20 dB.
Tuned to 446252000 Hz.
Oversampling input by: 84x.
Oversampling output by: 1x.
Buffer size: 8.13ms
Exact sample rate is: 1008000.009613 Hz
Sampling at 1008000 S / s.
Output at 12000 Hz.
Reading raw data 'stdin': Signed 16 bit Little Endian, Frequency 12000 Hz, Mono
All works! But when restarting the raspberry pi everything again become like before and I have to start this cycle again: /

If someone has an idea to remedy it

neuron
Posts: 15
Joined: Wed May 24, 2017 10:48 pm

Re: Problem with FC0012 Tuner & librtlsdr0

Post by neuron » Tue Jul 04, 2017 11:15 pm

Raff94 wrote:Hello,

I have a problem with my Tuner FC0012:

...
Something is wrong ...

Please describe the tools or if you git and compile

You have rtl_fm, rtl_power, rtl_test and
whereis is librtlsdr?

Remove all rtl_* and librtlsdr
and git the source code

Installing the drivers:

1. Open a terminal

2. Update your distribution.
sudo apt-get update

3.
sudo apt-get install git
sudo apt-get install cmake
sudo apt-get install build-essential

4. Retrieve, build and compile the RTL2832U Osmocom drivers.
git clone git://git.osmocom.org/rtl-sdr.git
cd rtl-sdr/
mkdir build
cd build
cmake ../ -DINSTALL_UDEV_RULES=ON
make
sudo make install
sudo ldconfig
sudo cp ../rtl-sdr.rules /etc/udev/rules.d/

5. Blacklist the default driver
Open your /etc/modprobe.d folder
Create a new file 'blacklist-rtl.conf' as an administrator.
"blacklist dvb_usb_rtl28xxu"
Save the file, restart the machine.

6. Test the dongle :
rtl_test -t

Model, power supply and you test in different USB ports?

Regards,
Ruy

Alzibiff
Posts: 1
Joined: Thu Jul 27, 2017 12:02 pm

Re: Problem with FC0012 Tuner & librtlsdr0

Post by Alzibiff » Thu Jul 27, 2017 12:14 pm

I have exactly the same problem and although my installation was exactly as described by Ruy, I did it all again. (Never works, I know - these are computers and are very good at giving you the same information after the same input ;) ), I get the same problem - "No supported tuner found".

The procedure listed originally by neuron confirms that the hardware is working which means it MUST be a software problem. All help gratefully received.

Hardware is a generic dongle from an auction site plugged into the latest RPi running rasbian downloaded and updated this month. The dongle works when plugged into my Win10 laptop so again - a positive test of the hardware, it is all down to the RPi server.

Alan

ps Thinking about it - and I am no Linux guru by any stretch of the imagination - the install of librtlsdr0 must set some system flag / value which remains set when the package is later uninstalled. This would explain why installing and then removing the package enables the FC0012 to be discovered until a reboot - when none of the librtlsdr0 files or settings are in place. (Or is all that nonsense?).

Rambler
Posts: 1
Joined: Wed Aug 30, 2017 6:45 pm

Re: Problem with FC0012 Tuner & librtlsdr0

Post by Rambler » Wed Aug 30, 2017 6:47 pm

I am having this same exact issue. FC0012 tuner, same symptoms, messages, etc. were you ever able to resolve the problem?

thommo17
Posts: 1
Joined: Wed Oct 18, 2017 1:28 am

Re: Problem with FC0012 Tuner & librtlsdr0

Post by thommo17 » Wed Oct 18, 2017 1:36 am

Hi Guys,

I unfortunately was sent 2 FC0012 dongles from 2 seperate Ebay sellers instead of the R820T's it was meant to be and I am also having this exact same thing happen.

Did you end up finding a permanent solution at all?

Thanks

User avatar
ab1jx
Posts: 9
Joined: Mon Jun 19, 2017 2:24 pm
Location: Heath, MA USA

Re: Problem with FC0012 Tuner & librtlsdr0

Post by ab1jx » Fri Mar 01, 2019 7:22 pm

I'm seeing it in 2019 under Raspbian with librtlsdr-dev (0.5.3-11) and librtlsdr0 (0.5.3-11) installed. But I also have rtl-sdr from git August 2018. It's a mismatch of versions, but the dates on the executables match the git date. I wanted librtlsdr especially because I'm writing a program using it.

I took out the git version executables which were in /usr/local/bin and now I don't get that error anymore. The version of rtl_fm from the debs is in /usr/bin

I'm trying to decode Lojack signals with multimon like
rtl_fm -M fm -p 59 -f 173075000 - | multimon -v 10 -t raw -a AFSK1200
but it's still not working

Post Reply