Do you need a high performance pc to play SDR?

Main forum to discuss RTL-SDR related topics.
Post Reply
Github
Posts: 21
Joined: Sun Jan 28, 2018 6:33 pm

Do you need a high performance pc to play SDR?

Post by Github » Sat Feb 24, 2018 7:57 am

Do you need a high performance to decode digital voice and other stuff? I am currently using my ultrabook to play rtl-sdr but I notice the noise from cooling fan is so loud even when I am decoding analog voice. And sometimes my ultrabook is getting pretty hot and cpu is being throttled. So I am wondering is it necessary to build a new desktop? Is i5-8400 and 16 gig ram enough?

hotpaw2
Posts: 94
Joined: Sat Jan 14, 2017 11:07 pm
Contact:

Re: Do you need a high performance pc to play SDR?

Post by hotpaw2 » Sat Feb 24, 2018 6:04 pm

I use a tiny Raspberry Pi 3 for demodulating analog AM and FM from a RTL-SDR. No problem. No fan noise. The heat sink on the Pi only gets slightly warm. I also can carry my iPad, Pi, and antenna far away from the RF noise of big PCs and household electronics. A Pi Zero W might also work if you want something even smaller and lower power.
Last edited by hotpaw2 on Sun Feb 25, 2018 7:20 pm, edited 1 time in total.

User avatar
m_a_x
Posts: 45
Joined: Sat Sep 13, 2014 10:13 pm

Re: Do you need a high performance pc to play SDR?

Post by m_a_x » Sat Feb 24, 2018 10:33 pm

I have heard people decoding Tetra with old Pentium dual core used for SDR only.
Internet and all the services associated are taking a lot of resources and they should be reduced to the minimum needed to download drivers and updates for the sdr software. Usually this is done using laptops that have their own monitor.
Of course you need another pc for internet and all the other software.

rtlMJ
Posts: 3
Joined: Mon Feb 26, 2018 5:34 pm
Location: Norway

Re: Do you need a high performance pc to play SDR?

Post by rtlMJ » Mon Feb 26, 2018 5:43 pm

I found that cpu usage dropped when i display just waterfall or spectrum not both. When i had turned on all the noise reduction filters the sound stuttered because of my OLD laptop and the answer was to disable waterfall and spectrum view.

Post Reply