Page 1 of 1

USING MINI DIGITAL TV STICK RTL2832U 820T2 & SDR ON GNRC

Posted: Mon Jul 30, 2018 11:48 pm
by aecs
Good afternoon everyone.

I write here to see if any of you know that installation errors I may have had to use the r820t2 in gnu radio companion.

I'm trying to make an FM receiver and other analog TV receiver but when running the program does not receive any type of signal and the view errors, I have: devices not supported. I believe that this is some driver to be installed but I don't know where or how.

The steps that I have followed for installation (Ubuntu 16.04 LTS) have been:

1. Install gnuradio.
2. Install Xenial Xerius specifications (it is supposed to do I need for my version of Ubuntu).
I3. nstall specifications of gr-osmosdr to enable some features of the chip.

The Stick comes with a CD but i do not know how to install it since, according to the specifications only works for WXP, 2000, Vista, 7 and 8; and it is something that it seems strange to me since I have seen videos where they use this same model of stick to carry out projects in Gnuradio on Ubuntu.

Please, if any of you know that i need to install It would serve as much help as I am a novice programmer and i need to resolve this problem for my project.

Re: USING MINI DIGITAL TV STICK RTL2832U 820T2 & SDR ON GNRC

Posted: Tue Jul 31, 2018 10:38 pm
by rtlsdrblog
Did you install the RTL-SDR drivers?

Re: USING MINI DIGITAL TV STICK RTL2832U 820T2 & SDR ON GNRC

Posted: Thu Aug 02, 2018 9:13 pm
by aecs
I tried with this:

sudo apt-get update
sudo apt-get install git
sudo apt-get install cmake
sudo apt-get install build-essential
sudo apt-get install libusb-1.0-0-dev

git clone git://git.osmocom.org/rtl-sdr.git
cd rtl-sdr/
mkdir build
cd build
cmake ../ -DINSTALL_UDEV_RULES=ON
make
sudo make install
sudo ldconfig
sudo cp ../rtl-sdr.rules /etc/udev/rules.d/

Opening /etc/modprobe.d folder
Creating a new file 'blacklist-rtl.conf' and add this one line:
blacklist dvb_usb_rtl28xxu

rtl_test -t

I tried those commands but I do not know if I need to install something else because GNRC still says: "FATAL: No supported devices found to pick from"...

Re: USING MINI DIGITAL TV STICK RTL2832U 820T2 & SDR ON GNRC

Posted: Sat Aug 04, 2018 5:26 am
by rtlsdrblog
So does rtl_test work?

What source are you using in GNU Radio?

My guess is an issue with gr-osmosdr as this is what provides RTL-SDR support on GNU Radio. Double check that you've enabled RTL-SDR support for gr-osmosdr. Some notes here https://github.com/ptrkrysik/gr-gsm/issues/136.

Re: USING MINI DIGITAL TV STICK RTL2832U 820T2 & SDR ON GNRC

Posted: Sat Aug 04, 2018 12:55 pm
by aecs
Yes, the system recognizes the RTL when i make rtl_test -t.

The source I have on GRC is RTL-SDR source.

Well, I try to install everything again using Synaptic, and I install the gr-osmosdr packet with its dependencies again, but still exist the error on GRC.

I am going to read what you share with me, thanks!

Re: USING MINI DIGITAL TV STICK RTL2832U 820T2 & SDR ON GNRC

Posted: Sat Aug 04, 2018 1:34 pm
by aecs
I tried with that, but it seems that everything is correct:

[email protected]:~/rtl-sdr$ cmake -DENABLE_RTL=ON
-- Build type not specified: defaulting to release.
-- Extracting version information from git describe...
-- Building with kernel driver detaching disabled, use -DDETACH_KERNEL_DRIVER=ON to enable
-- Building for version: 0.5.4-9-g9047 / 0.6git
-- Using install prefix: /usr/local
-- Configuring done
-- Generating done
-- Build files have been written to: /home/david/rtl-sdr

[email protected]:~/rtl-sdr$ sudo apt-get install librtlsdr-dev
[sudo] password for david:
Lo sentimos, vuelva a intentarlo.
[sudo] password for david:
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
librtlsdr-dev ya está en su versión más reciente (0.5.3.17-myriadrf1~xenial).
Los paquetes indicados a continuación se instalaron de forma automática y ya no son necesarios.
dkms fonts-horai-umefont fonts-unfonts-core gnome-exe-thumbnailer
libappindicator1 libcaca0:i386 libcurl3:i386 libgif7:i386 libglfw3
libgnuradio-analog3.7.9 libgnuradio-atsc3.7.9 libgnuradio-audio3.7.9
libgnuradio-blocks3.7.9 libgnuradio-channels3.7.9 libgnuradio-comedi3.7.9
libgnuradio-digital3.7.9 libgnuradio-dtv3.7.9 libgnuradio-fcd3.7.9
libgnuradio-fec3.7.9 libgnuradio-fft3.7.9 libgnuradio-filter3.7.9
libgnuradio-fosphor3.7.0 libgnuradio-iqbalance0 libgnuradio-noaa3.7.9
libgnuradio-pager3.7.9 libgnuradio-qtgui3.7.9 libgnuradio-rds3.7.0
libgnuradio-trellis3.7.9 libgnuradio-uhd3.7.9 libgnuradio-video-sdl3.7.9
libgnuradio-vocoder3.7.9 libgnuradio-wavelet3.7.9 libgnuradio-wxgui3.7.9
libgnuradio-zeromq3.7.9 libgps22 libgsf-1-114 libgsf-1-common libgsoap8
libhidapi-libusb0 libice6:i386 libindicator7 libllvm5.0 libllvm5.0:i386
libmsi0 libp11-kit-gnome-keyring:i386 libqt5x11extras5 librtmp1:i386
libsdl1.2debian:i386 libslang2:i386 libsm6:i386 libsoapysdr0
libsoapysdr0.5-2 libuhd003 libvncserver1 libxmu6:i386 libxt6:i386
linux-headers-4.10.0-28 linux-headers-4.10.0-28-generic
linux-headers-4.13.0-38 linux-headers-4.13.0-38-generic
linux-headers-4.13.0-41 linux-headers-4.13.0-41-generic
linux-headers-4.13.0-43 linux-headers-4.13.0-43-generic
linux-image-4.10.0-28-generic linux-image-4.13.0-38-generic
linux-image-4.13.0-41-generic linux-image-4.13.0-43-generic
linux-image-extra-4.10.0-28-generic linux-image-extra-4.13.0-38-generic
linux-image-extra-4.13.0-41-generic linux-image-extra-4.13.0-43-generic
msitools odbcinst odbcinst1debian2 p11-kit-modules:i386 unixodbc
virtualbox-dkms wine-gecko2.21 wine-gecko2.21:i386 wine-mono0.0.8
Utilice «sudo apt autoremove» para eliminarlos.
0 actualizados, 0 nuevos se instalarán, 0 para eliminar y 0 no actualizados.