Discuss RTL-SDR and cheap software defined radio
It is currently Sat Oct 21, 2017 5:02 am

All times are UTC

Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: RTL-SDR and Ubuntu 14.04
PostPosted: Sun Jul 27, 2014 4:53 pm 

Joined: Sun Jul 27, 2014 4:28 pm
Posts: 1
After many years of microsoft, I have finally had it. May have been a mistake, but I put in a new drive with Ubuntu only, and am now struggling to learn it!
But the question is:
I have a RTL-SDR dongle hooked up to my FT-950 and want to run it as a panadapter. I found some software that is linux, and have been installing a bunch of stuff and it still is not working. Probably installed stuff I don't really need, but I can find nowhere a list of the software needed or a "package" to make it work.
So, needed one guru to walk me thru this. I refuse to put Windows back on this machine even though it may be easier to install!

PostPosted: Tue Aug 26, 2014 2:06 am 

Joined: Tue Aug 26, 2014 2:01 am
Posts: 1
I had rtl-sdr running just fine on CentOS 7 but I switched to Ubuntu 14 and now even though all the packages installed just fine I can't get anything out of the rtl except noise. I get no errors and the drivers loaded just fine. I have no idea what is wrong.

PostPosted: Wed Aug 27, 2014 4:41 am 
Site Admin

Joined: Mon Nov 19, 2012 11:54 pm
Posts: 1193
Cptnmike: Instructions as follows

sudo apt-get install git
sudo apt-get install cmake
sudo apt-get install libusb-1.0-0.dev
sudo apt-get install build-essential

git clone git://git.osmocom.org/rtl-sdr.git
cd rtl-sdr/
mkdir build
cd build
sudo make install
sudo ldconfig
cp ../rtl-sdr.rules /etc/udev/rules.d/

Then to stop the conflicting Linux DVB-T drivers from loading make a text file "Blacklist-rtl.conf” in /etc/modprobe.d and in the text file write blacklist dvb_usb_rtl28xxu.

After installing the drivers you'd probably want to install something like GQRX http://gqrx.dk/

kholt: What software are you using that you just see noise?

PostPosted: Thu Apr 27, 2017 6:48 am 

Joined: Thu Apr 27, 2017 6:24 am
Posts: 1
on linux mint 18.1 Cinnamon 64-bit
in my case blacklist dvb_usb_rtl28xxu does not work
but i solved the problem of loading the conflicting Linux DVB-T drivers
by blacklisting fc0013
I create a file in /etc/modprobe.d with [name you want] .conf extension contents:

blacklist fc0013

then restart.

it work for me

my method:

i run lsmod with Linux DVB-T drivers on
unplug the RTL dongle and run
sudo rmmod dvb_usb_rtl28xxu rtl2832 [disable DVB-T drivers]
i plug the RTL dongle and run lsmod again
compare two results and test

PostPosted: Thu Apr 27, 2017 7:06 am 

Joined: Fri Apr 08, 2016 8:43 pm
Posts: 35
I wrote a guide for the RTL's in Linux:

https://ranous.files.wordpress.com/2016 ... v10-16.pdf

It doesn't have anything specifically for using one as a panadapter with your Yaesu.

If Ubuntu drives you nuts, give Linux Mint a try.


Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC

Who is online

Users browsing this forum: Bing [Bot] and 2 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Powered by phpBB® Forum Software © phpBB Group