Installation Problem with ge-dect2

Need help installing or figuring out something about your SDR? Ask here.
Post Reply
Posts: 3
Joined: Sun Jul 10, 2016 12:51 pm

Installation Problem with ge-dect2

Post by OKCarl » Sun Jul 10, 2016 12:53 pm

I am on Ubuntu 16.04 LTS. My first step, install the dependencies: gnuradio, cmake, swig, and boost using synaptic package manager. Then I tried to install the script: gr-dect2.

Problems developed at this line of code in my terminal:

~/gr-dect2/build$ cmake ../

Dozens of lines of error messages popped on the screen. Beginning with:

“CMake error at /usr/share/cmake-3.5/Modules/CmakeDetermineSystem.cmake :184 (file): file failed to open for writing (No such file or directory):”

Further down in the error message I find:

“The C++ compiler “/usr/bib/c++ is not able to compile a simple test program.

It fails with the following output:

Cmake will not be able to correctly generate this project. Call stack (most recent call first) : CMakeLists.txt:25 (project)”

I have no idea what this means. Can anyone :?: help?

Site Admin
Posts: 2942
Joined: Mon Nov 19, 2012 11:54 pm

Re: Installation Problem with ge-dect2

Post by rtlsdrblog » Mon Jul 11, 2016 3:12 am

Never tried gr-dect, but this looks probably like a permissions error. Make sure you are a root user, or use sudo.

Post Reply