Page 1 of 1

Failed to open rtlsdr device #0.

Posted: Sun Apr 23, 2017 1:59 am
by steveo250k
I'm trying to use DVB-T+DAB+FM+SDR dongle on Windows 8.1.
Ultimately I'm trying to use GNURADIO Companion.

The dongle works with SDRSharp.

But I can't connect with GNURadio or RTL-SDR. When I run rtl_test -t I get:
c:\Temp\GNURadio_Tutorals\rtl-sdr-release\x64>rtl_test -t
Found 2 device(s):
0: , , SN:
1: Realtek, RTL2838UHIDIR, SN: 00000001

Using device 0: Generic RTL2832U OEM
usb_open error -12
Failed to open rtlsdr device #0.

Any idea what the problem is?

Re: Failed to open rtlsdr device #0.

Posted: Mon Apr 24, 2017 12:30 am
by rtlsdrblog
The usual problem is that you either haven't blacklisted the DVB-T drivers (blacklist dvb_usb_rtl28xxu), or the rules.d file hasn't been copied over during the RTL-SDR driver install process.

Re: Failed to open rtlsdr device #0.

Posted: Sat Mar 31, 2018 12:14 pm
by amck
Had the same problem on a Raspberry Pi system.

Problem was the system service was still running and using the rtlsdr. Maybe your test isn't working because some other software has already got use of the rtlsdr

Re: Failed to open rtlsdr device #0.

Posted: Tue May 15, 2018 2:26 am
by Kdawg_pi_user
Amck,

I am having trouble during the 'rtl_test' as well. I have blacklisted dvb_usb_rtl28xxu and the rules have been copied to /etc/udev/rules.d.

Error during test:
Image

Blacklisted:
Image

Any advise would be appreciated.

Re: Failed to open rtlsdr device #0.

Posted: Tue May 15, 2018 5:29 am
by rtlsdrblog
Images are broken. Could I also know what OS?

Try blacklisting dvb_usb_rtl2832u as well.

Re: Failed to open rtlsdr device #0.

Posted: Fri May 18, 2018 9:54 am
by Username
Image

Re: Failed to open rtlsdr device #0.

Posted: Thu May 24, 2018 2:51 am
by Kdawg_pi_user
Sorry about that. Google share is not working for me apparently.

I am running the latest version of Raspbian on the Raspberry Pi 3. I have followed Kenn Ranous' guide to the tee. Wiped and reinstalled the OS. Then followed Kenn Ranous' guide to the tee again and same results.

I run rtl_test -t and I get the proper feed back. Then I install gqrx. When I launch it the program never loads.

Re: Failed to open rtlsdr device #0.

Posted: Thu May 24, 2018 2:57 am
by rtlsdrblog
How did you install GQRX?

Re: Failed to open rtlsdr device #0.

Posted: Sat Aug 11, 2018 2:43 pm
by Husker84
I’m having the same issue.

I tried recompiling using

Code: Select all

cmake ../ -DINSTALL_UDEV_RULES=ON -DDETACH_KERNEL_DRIVER=ON
And don’t work.

Also tried to made a config file at "/etc/modprobe.d/" as follows.

>blacklist dvb_usb_rtl28xxu
>blacklist rtl2830
>blacklist rtl2832
>blacklist dvb_usb_v2
>blacklist dvb_core

Restarting, and still don’t works.

https://imgur.com/a/lpnuWuz



In a Windows system it works like a charm.

Any idea?

Re: Failed to open rtlsdr device #0.

Posted: Tue Dec 03, 2019 8:36 am
by unalfaruk
I also had the same problem,

The output for "rtl_test.exe":

Code: Select all

Found 2 device(s):
  0:  , , SN: 
  1:  Realtek, RTL2838UHIDIR, SN: 00000001

Using device 0: Generic RTL2832U OEM
usb_open error -12
Failed to open rtlsdr device #0.
MY SOLUTION
You should indicate your device using "-d" parameter. For me it was: "rtl_test.exe -d 1"

Code: Select all

Found 2 device(s):
  0:  , , SN: 
  1:  Realtek, RTL2838UHIDIR, SN: 00000001

Using device 1: Generic RTL2832U OEM
Found Rafael Micro R820T tuner
Supported gain values (29): 0.0 0.9 1.4 2.7 3.7 7.7 8.7 12.5 14.4 15.7 16.6 19.7 20.7 22.9 25.4 28.0 29.7 32.8 33.8 36.4 37.2 38.6 40.2 42.1 43.4 43.9 44.5 48.0 49.6
Sampling at 2048000 S/s.

Info: This tool will continuously read from the device, and report if
samples get lost. If you observe no further output, everything is fine.

Reading samples in async mode...
lost at least 20 bytes
Signal caught, exiting!