Bias-t stops working

Need help installing or figuring out something about your SDR? Ask here.
phil
Posts: 50
Joined: Mon Aug 21, 2017 11:02 pm

Bias-t stops working

Post by phil » Mon Aug 21, 2017 11:08 pm

G’day,
I’m having an issue with the bias-t stopping when i run gr-iridium or multimon-ng in ubuntu 16.04. There is no indication in the command window that it has stopped, but if i give it the off command, i get an access error. When i use any other program (gqrx + decoders, or rtl_433 for example), the bias-t stays active. Thought it might be a blacklist issue, so i have done that. Any ideas please?

rtlsdrblog
Site Admin
Posts: 2321
Joined: Mon Nov 19, 2012 11:54 pm

Re: Bias-t stops working

Post by rtlsdrblog » Tue Aug 22, 2017 12:47 pm

What version of the RTL-SDR drivers are you running? Also can I see the exact commands that you are using for gr-iridium and multimon-ng as well?

I think what's happening is that you might be using the latest osmocom drivers. These added bias tee support, but unforunately they reset the bias tee to OFF every time it starts unless the -T flag is specified. So you have to find a way to specify the -T flag to the command line flags if you're using those drivers.

You could also try revert to older drivers, or modify the osmocom driver code to remove the calls to rtlsdr_set_bias_tee.

phil
Posts: 50
Joined: Mon Aug 21, 2017 11:02 pm

Re: Bias-t stops working

Post by phil » Tue Aug 22, 2017 10:19 pm

thanks for getting back to me. these are the commands i'm using:

iridium: iridium-extractor -D4 examples/rtlsdr.conf | grep "A:OK" > output.bits

multimon-ng (for xastir) : rtl_fm -f 145.1750000M fm -s 22050 -g 16.0 -A fast -l 0 |multimon-ng -a AFSK1200 -A -t raw - | sed -u 's/.{6}//' | socat STDIN TCP-LISTEN:14580,reuseaddr,fork

I don't know how to find what version of the driver i am using (or how to revert), if you have any info on that please.

as of yesterday, the bias-t now won't work with any other program, and i get the "usb claim interface error -6" error.

thanks for your time!

rtlsdrblog
Site Admin
Posts: 2321
Joined: Mon Nov 19, 2012 11:54 pm

Re: Bias-t stops working

Post by rtlsdrblog » Wed Aug 23, 2017 6:29 am

usb claim interface error -6 means that some other program is currently accessing the SDR.

How did you install the drivers? Did you use apt-get or install from source?

Try do a rtl_fm -h, and see if it has the -T flag for the bias tee. You could then specify that flag for multimon at least.

phil
Posts: 50
Joined: Mon Aug 21, 2017 11:02 pm

Re: Bias-t stops working

Post by phil » Wed Aug 23, 2017 8:57 am

awesome! -T option works for multimon-ng thanks. the bias-t drivers were installed via the .V3 guide git clone method. would it make any difference if re-install the drivers? is there a correct proceedure to completely remove them?

rtlsdrblog
Site Admin
Posts: 2321
Joined: Mon Nov 19, 2012 11:54 pm

Re: Bias-t stops working

Post by rtlsdrblog » Wed Aug 23, 2017 11:38 am

Ah okay yeah then you're on the latest Osmocom version.

Unfortunately/fortunately they recently updated their drivers and they now have built in bias tee support. Sounds good, but i've now found that the problem is that in their rtl_fm and other software init code they reset the bias tee to off if no -T flag is specified. So if you turn the bias tee on with our program, then run rtl_fm without the -T flag then the bias tee will reset to off.

For gr-iridium i'm not too sure how that works and how it accesses the RTL-SDR, so not too sure how to fix it. Instead I would first try to install the keenerd version of the drivers from https://github.com/keenerd/rtl-sdr. Use the same instructions but replace the github link with that one. Those drivers dont have the bias tee support built in, so they shouldnt reset the bias tee if you turn it on using our program first.

phil
Posts: 50
Joined: Mon Aug 21, 2017 11:02 pm

Re: Bias-t stops working

Post by phil » Thu Aug 24, 2017 12:00 am

thanks, yeah, i'm not sure how iridium accsesses the dongle either. there are a set of examples (rules/config) for hackrf, airspy and rtl-sdr within the program so there may be a way to add the bias-t switch there somehow. the hackrf rules show an option for a preamp, so it may be possible. i'm really hoping someone will see this and find a solution, the L-band stuff cant be done without the LNA working.

rtlsdrblog
Site Admin
Posts: 2321
Joined: Mon Nov 19, 2012 11:54 pm

Re: Bias-t stops working

Post by rtlsdrblog » Thu Aug 24, 2017 6:49 am

Failing a solution to that, just try the keenerd drivers. That should give you the ability to use our rtl_biast program to turn the bias tee on, and leave it on no matter what you do after.

phil
Posts: 50
Joined: Mon Aug 21, 2017 11:02 pm

Re: Bias-t stops working

Post by phil » Thu Aug 24, 2017 9:14 am

no worries, i installed those drivers earlier, still unsure of how to tell gr-iridium to use them though.

rtlsdrblog
Site Admin
Posts: 2321
Joined: Mon Nov 19, 2012 11:54 pm

Re: Bias-t stops working

Post by rtlsdrblog » Fri Aug 25, 2017 7:00 am

With those drivers you just use the rtl_biast software to turn the bias tee on first.

Then afterwards use gr-iridium however you want. The idea is that the keenerd drivers wont reset the bias tee to OFF everytime you start gr-iridium.

Post Reply