Page 1 of 1

Running 2 Dongles on a Pi

Posted: Sat Nov 04, 2017 1:21 pm
by Izze
Hi,

I just started doing things in Linix using a Pi just a week ago. So I am a newbie and a german. :shock:

I am running a Raspberry Pi 3 and use this with a dongle to feed FR24 and FlightAware.
That works fine.

Now, I bought another dongle (NooElec TV28T v2 USB DVB-T & RTL-SDR Receiver, RTL2832U & R820T Tuner) to receive radio.
I thought, I need a second receiver for the radio thing because the first one is "blocked" by ads-b. Is this right?

The first dongle works perfect.
Now I want to start a sdr server using the second dongle and get the following messages:

Code: Select all

sudo rtl_tcp -a 192.168.2.30 -p 1234 -d 1
Found 2 device(s):
  0:  Realtek, RTL2838UHIDIR, SN: 00000001
  1:  Realtek, RTL2838UHIDIR, SN: 00000001

Using device 1: Generic RTL2832U OEM
Found Rafael Micro R820T tuner
[R82XX] PLL not locked!
Tuned to 100000000 Hz.
rtl_tcp: symbol lookup error: rtl_tcp: undefined symbol: rtlsdr_set_bias_tee

Code: Select all

sudo rtl_test -t -d 1
Found 2 device(s):
  0:  Realtek, RTL2838UHIDIR, SN: 00000001
  1:  Realtek, RTL2838UHIDIR, SN: 00000001

Using device 1: Generic RTL2832U OEM
Found Rafael Micro R820T tuner
Supported gain values (29): 0.0 0.9 1.4 2.7 3.7 7.7 8.7 12.5 14.4 15.7 16.6 19.7 20.7 22.9 25.4 28.0 29.7 32.8 33.8 36.4 37.2 38.6 40.2 42.1 43.4 43.9 44.5 48.0 49.6 
[R82XX] PLL not locked!
Sampling at 2048000 S/s.
No E4000 tuner found, aborting.
I don't know what to do.
What I am dioing wrong here?

Thank you for help!

Re: Running 2 Dongles on a Pi

Posted: Sat Nov 04, 2017 5:48 pm
by tim_rtd
I don't see anything really wrong. Don't use the rtl_test -t..that's for the E4000 only.
Leave off the -t..
Start 2nd server rtl_tcp -d 1 -a 192.168.1.100 ... you differentiate dongles by -d 0 or -d 1 ...-d 2... and different port #
There may be a variant of rtl_tcp that wants you to define t-bias on or off......try rtl_tcp -h

You don't have to use rtl_test at all..I use it to see which dongle is 0,1,2,,,,etc

So ... rtl_tcp -d 1 -a 102.168.1.xxx -p 1235 & ...should work...then you need a client app to listen to the tcp stream like sdrSharp.

or GQRX inside the rpi itself......then you don't need rtl_tcp at all...

Re: Running 2 Dongles on a Pi

Posted: Sat Nov 04, 2017 5:57 pm
by Izze
tim_rtd wrote:
Sat Nov 04, 2017 5:48 pm
Start 2nd server rtl_tcp -d 0 -a 192.168.1.100 ... you differentiate dongles by -d 0 or -d 1 ...-d 2... and different port #
Thats what I do. See first code window, there are errors at the end and it wont start.

Re: Running 2 Dongles on a Pi

Posted: Sat Nov 04, 2017 6:18 pm
by tim_rtd
Hi Izzy, I edited my reply to you...hope it helps a little more

Re: Running 2 Dongles on a Pi

Posted: Sat Nov 04, 2017 6:33 pm
by Izze
tim_rtd wrote:
Sat Nov 04, 2017 6:18 pm
Hi Izzy, I edited my reply to you...hope it helps a little more
Thx, I will see what I can do tomorrow, thank you!

Re: Running 2 Dongles on a Pi

Posted: Sun Nov 05, 2017 2:40 am
by rtlsdrblog
rtl_tcp: symbol lookup error: rtl_tcp: undefined symbol: rtlsdr_set_bias_tee

That error usually indicates some sort of driver conflict. I'd try first to uninstall all traces, and reinstall from scratch. If it's still not working, try installing an alternative like keenerds RTL-SDR version.

Also as someone also commented pay attention to specifying the correct dongle with the -d flag.

Re: Running 2 Dongles on a Pi

Posted: Sat Jan 12, 2019 6:56 pm
by keukenrol
I am having the same error over here, how did you solve it?

Edit: solution here:
https://forum.flightradar24.com/threads ... DR-package