Page 1 of 1

SDR shows up with two bulk-in interfaces

Posted: Sun Jul 08, 2018 9:49 pm
by traceur
I have two SDR's (A NESDR Smart, and a RTL-SDR v3) which were working fine three days ago. Last night my computer decided to do a windows update, which wiped out the drivers. No surprise there. But when I plug in either of the SDR's they show up as two bulk-in interfaces each (both in Device Manager and in zadig).
DManager.jpg (99.51 KiB) Viewed 18084 times
Then when both are plugged in it shows up as four, Bulk-in (0) to Bulk-in (3).
SDRcontr.jpg (38.81 KiB) Viewed 18084 times
I can still get them to work in SDR# by using the two that work. (The other two fail to start.) But Unitrunker has trouble figuring it out and can only get one of the SDR's running. So, I'm looking for help. Is there a reason for it showing up as two bulk-in interfaces? Can I fix it and recombine them back into one? I have already tried updating the drivers, removing/uninstalling the devices and reinstalling the drivers, restarting the programs, and my computer multiple times, and even reinstalling the USB drivers. I'm at a loss of what to do next.

Re: SDR shows up with two bulk-in interfaces

Posted: Wed Jul 11, 2018 12:15 am
by rtlsdrblog
Weird, no idea why or how Windows would show it that many times.

I'd try uninstalling all the drivers, and then installing again.

Re: SDR shows up with two bulk-in interfaces

Posted: Wed Nov 21, 2018 5:35 pm
by WhirlPool
I'm having this problem too.


Tried uninstalling and removing the drivers.
Reinstalled using Zadig 2.4 and the result is the same.

It's not a big issue as the devices work.
It's just annoying ...

Re: SDR shows up with two bulk-in interfaces

Posted: Wed Dec 19, 2018 12:15 pm
by pashpe
OK, I have the same issue with lost audio. Installed on a Win10 machine, worked without issue. Then I plugged the RTL-SDR into a different USB port, and now AirSpy shows two Bulk-In interfaces, 0 and 1 whereas the prior successful operation only showed interface 0. So, I verified driver, and tried using interface 1. It appears to work as I selected known FM broadcast station and there is activity displayed but now no audio. So I uninstalled all that I could find and started again, and AirSpy still shows two devices, and interface 0 no longer installed. So where in the computer is the hidden driver or configuration file that is causing this issue? Anyone know? Moving to a different USB port is my best analysis as to the start of my woes. Thanks in advance for a solution.

Re: SDR shows up with two bulk-in interfaces

Posted: Thu Jan 31, 2019 8:50 am
by beast6228
Usually you will get several devices if you switch usb ports. The only way to fix it is by uninstalling the drivers, clean your system of ghost drivers by using Device Cleanup and then reinstall the drivers.

Re: SDR shows up with two bulk-in interfaces

Posted: Fri Feb 01, 2019 7:34 pm
by Corrosive
I wish I had a solution for that... The tablet in my car is Windows 10 and I have 3 SDRs attached to it.
For some reason after an update I one of them showing up with double the interfaces. This only happens with one of the three which is even more strange.