Page 1 of 1

No Device Selected Tried Everything Listed Everywhere to Solve

Posted: Sun Oct 07, 2018 5:04 am
by Murphy625
I'm getting the dreaded "No Device Selected" error. When I click on the gear in the upper left corner of the SDSharp software, the device selection is grayed out with only an E400 showing above what's supposed to be a dropdown box.

I'm using Win8.1 pro. Ran everything under ADMIN.. The Instal-rtlsdr.bat "seems" to run fine but it goes to fast to see anything happen and then the window closes.

The device shows up in my device manager just fine.

Tried running the 64 bit and 32 bit versions, same error.

Tried uninstalling everything and reinstalling.. same error.

Tried running the zadig.exe file under admin and reinstalling things. Under show all devices, mine shows as RTL2838UHIDIR.. Tried reinstalling the WinUSB (v6.1.7600.16385) driver several times..

Tried switching from USB 3.0 port to a USB 2.0 port and same error.

Nothing seems to work.

I bought this device a year ago and it DID WORK.. Used it for an hour and packed it away the next day when my ICOM Ham Radio showed up in the mail. I've spent a year studying antenna design, ham radio, digital signal modes, repeaters, etc.. Then decided to give the SDR another looksy but now it won't work. Same computer.

Any suggestions? I've spent almost 4 hours trying to get this thing to work..

Re: No Device Selected Tried Everything Listed Everywhere to Solve

Posted: Sun Oct 07, 2018 6:11 am
by Murphy625
Almost 6 hours on this now.. Rebooted probably 15 times.. Tried uninstalling drivers, reinstalling drivers, 64bit version, 32 bit version..

Nothing.

And now, when I try to use the ZADIG.exe to "reinstall driver", its says installation failed.

I guess you do get what you pay for.... I'm starting to get the feeling I got taken for my $28 because this thing doesn't work.

Re: No Device Selected Tried Everything Listed Everywhere to Solve

Posted: Sun Oct 07, 2018 7:06 am
by Murphy625
UPDATE:
Still doesn't work, however:

I fixed the problem with failed driver install from the zadig.exe by deleting the USB directory under my user name.

Verified that the Install-RTLSDR.bat worked.
Verified that the proper dll files are in the sdr directory.
Verified that the dongle is seen in the device manager with the following attributes:
Driver Provider: libwdi
Driver Version: 6.1.7600.16385
Driver Signer: USB\VID_0BDA&PID_2838 (libwdi autogenerated)

I also downloaded and installed Net Framework 4.7 (although it doesn't seem to show in my registry as anything but version 4.0) The install said it was successful.

I also followed everything in this thread:
viewtopic.php?t=506

Nothing seems to be working. It has worked on this computer before.

Re: No Device Selected Tried Everything Listed Everywhere to Solve

Posted: Sun Oct 07, 2018 5:23 pm
by Murphy625
Got it working..

Had to use a different USB port. How stupid is that?

I have a G5RV 40 meter dipole about 100 feet up in a maple tree.. Time to see how this thing works with it.

Re: No Device Selected Tried Everything Listed Everywhere to Solve

Posted: Mon Oct 08, 2018 5:20 am
by rtlsdrblog
Might have just been a faulty/low quality USB port. On some PCs some extended USB ports like those on the front of the PC are connected with low quality cable, and that can cause issue with high data rate devices like SDRs.

Re: No Device Selected Tried Everything Listed Everywhere to Solve

Posted: Mon Oct 08, 2018 4:45 pm
by Murphy625
Its a Core I5 processor on an Asus motherboard with RealTek audio..

There are 6 USB ports on the motherboard connectors on the back of the case.

I built the computer myself... Go figure. Simply changing to another port fixed the problem immediately.

Re: No Device Selected Tried Everything Listed Everywhere to Solve

Posted: Wed May 15, 2019 8:33 pm
by jeremyb
Have just gone through a similar issue, 64bit windows 10, the 64bit driver simply doesn't work, I re-ran zadig after copying the 32bit driver into SDR Sharps directory and re-installed the driver, then it would show up in SDR Sharp :)