Page 1 of 1

Zadig.exe fails to install

Posted: Sat Dec 29, 2018 3:48 pm
by Nick
Hello,

I have just tried to install zadig.exe but it fails straight away with message it is not compatible with version of windows I am using (see attachment).

The computer is running Windows 7 Pro (64 bit) Service Pack 1, and has an intel i7 processor and 6 GByte of triple channel memory.

Tried a few different compatibility modes but no luck here.

The program was downloaded from https://airspy.com/download/

Any advice would be appreciated.

Regards,

Nick.

Re: Zadig.exe fails to install

Posted: Sun Dec 30, 2018 9:53 am
by rtlsdrblog
I found people discussing the same issue here https://github.com/pbatard/libwdi/issues/126

The conclusion is that it's something wrong with your system, but there is a very strange solution. They found that when downloading the file with Chrome zadig wouldn't run, but when downloaded with Edge browser, it worked fine.

So i'd suggest manually downloading it from https://zadig.akeo.ie/, using the Edge browser and seeing if that helps.

Re: Zadig.exe fails to install

Posted: Mon Dec 31, 2018 1:04 am
by jryx
I am assuming you did the install using "install-rtlsdr.bat". I did the setup yesterday and ran into the same problem (except I am on Windows 10 and it gave a different error that the file was either not and executable or corrupted...). I know it is the same problem because your zadig.exe file is 10 KB as was mine. The real file is about 5 MB.

The file downloaded is actually an html file. If you change the file extension from ".exe" to ".html", it will open as a web page saying "404 file not found." This means the real issue here is that the install file points to a dead link and doesn't download an executable at all. I suppose the zadig people shouldn't have changed their link, and Airspy needs to update the install file.

I would say download the file directly using the site linked by rtlsdrblog. I downloaded version 2.4 which seems to be the most recent and worked for me. Not sure what the browser issue is but I used Firefox for the record.

Re: Zadig.exe fails to install

Posted: Mon Dec 31, 2018 4:16 am
by rtlsdrblog
You are right, the admins of the zadig site have moved the location of the file, and now install-rtlsdr.bat points to the wrong link.

So for now, please download zadig via the official website.