Page 1 of 1

SDR# freezes spectrum and emits a high-pitched tone

Posted: Mon Apr 29, 2019 7:03 pm
by 13R56
Hi!

I updated SDR# to the latest version; I was experiencing a weird bug where the frequency at the top did not match the frequency displayed on the spectrum. Not long after the update, I experienced a weird glitch with the latest version where the spectrum freezes and SDR# just plays a constant high-pitched tone. I tried replacing SDR# in the folder that holds the program and related software with a fresh copy from the zip file that I had downloaded, but that did not solve the problem. I also reinstalled the RTL-SDR driver using Zadig, but that also made no difference. Is there anybody else experiencing this problem? I'm running up to date Windows 10 x64 on a stock Lenovo H50, if that helps.

Re: SDR# freezes spectrum and emits a high-pitched tone

Posted: Mon Apr 29, 2019 7:07 pm
by 13R56
The screenshot is of SDR# exactly as it appears if I click the "play" button.

Re: SDR# freezes spectrum and emits a high-pitched tone

Posted: Mon Apr 29, 2019 10:07 pm
by bmh
I have this same problem almost every time Windows 10 does an update and it's always ended up being the driver. I see where you said you already tried reinstalling it but I would try it again. You might want to consider checking your Device Manager too and look and see if there is more than one driver listed under the setting "Universal Serial Bus Devices". If there's more than one listing called "Bulk-In, Interface" then SDR# is probably looking at the wrong one. Under "View" in the Device Manager window also click "Show hidden devices" to see if other 'Bulk-In, Interface" listings are there. Delete any that aren't in use, especially the hidden ones that showed up when you clicked "Show hidden devices", being sure not to delete one for any other devices that you use that might not be connected at the time or you will have to reinstall them when you go to use them again.

Also always make sure you use the same USB port each time or otherwise you will have to run zadig again if you've changed to a different port other than the one you used when you installed the driver the first time.

Re: SDR# freezes spectrum and emits a high-pitched tone

Posted: Tue Apr 30, 2019 1:50 am
by 13R56
Update: I just pressed "play" expecting to hear the tone, and inexplicably SDR# is back to normal. I'll be damned if I have any idea as to what happened, or what changed. I did leave SDR# idle and stopped for a few hours, I wonder if that did something. *shrugs*