Errors on Rafael Micro R820T

Need help installing or figuring out something about your SDR? Ask here.
Post Reply
Legath
Posts: 1
Joined: Tue Feb 04, 2014 11:49 am

Errors on Rafael Micro R820T

Post by Legath » Tue Feb 04, 2014 11:54 am

Hi.
i have found strange issue on this device

Code: Select all

rtl_test -t
Found 1 device(s):
  0:  Generic, RTL2832U, SN: 77771111153705700

Using device 0: Generic RTL2832U
Found Rafael Micro R820T tuner
r82xx_write: i2c wr failed=-4 reg=1a len=7
r82xx_write: i2c wr failed=-4 reg=0c len=1
r82xx_init: failed=-4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
Supported gain values (29): 0.0 0.9 1.4 2.7 3.7 7.7 8.7 12.5 14.4 15.7 16.6 19.7 20.7 22.9 25.4 28.0 29.7 32.8 33.8 36.4 37.2 38.6 40.2 42.1 43.4 43.9 44.5 48.0 49.6 
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
WARNING: Failed to set sample rate.
No E4000 tuner found, aborting.
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_write_reg failed with -4
usb subsystem detect this

Code: Select all

usb 1-1: new full speed USB device using s3c2410-ohci and address 2
usb 1-1: New USB device found, idVendor=0bda, idProduct=2832
usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 1-1: Product: RTL2832U
usb 1-1: Manufacturer:Generic
usb 1-1: SerialNumber: 77771111153705700

rtlsdrblog
Site Admin
Posts: 2397
Joined: Mon Nov 19, 2012 11:54 pm

Re: Errors on Rafael Micro R820T

Post by rtlsdrblog » Tue Feb 04, 2014 10:06 pm

Haven't seen that error before, but with on Google I found references to people saying that it is probably a power issue. Have you got it connected to a long USB extension cable, low powered USB port, or mistakenly plugged it into a USB1.0 port? The dongle needs USB2.0 and some USB ports on embedded devices don't provide enough power without an externally powered cable/hub.

Post Reply