I cannot enable bias tee

Need help installing or figuring out something about your SDR? Ask here.
Post Reply
Posts: 3
Joined: Fri Jul 05, 2019 3:21 pm

I cannot enable bias tee

Post by alex27riva » Thu Aug 29, 2019 12:52 pm

Hi everyone, I cannot enable bias tee using RTL-SDR v3 using my Raspberry pi, when I run

Code: Select all

./rtl_biast -b 1
on my Raspberry, I get this error:

Code: Select all

Found 1 device(s):
  0:  Realtek, RTL2838UHIDIR, SN: 00000001

Using device 0: Generic RTL2832U OEM

Kernel driver is active, or device is claimed by second instance of librtlsdr.
In the first case, please either detach or blacklist the kernel module
(dvb_usb_rtl28xxu), or enable automatic detaching at compile time.

usb_claim_interface error -6
The is way to force the bias tee to turn on?

I tried adding cmake ../ -DINSTALL_UDEV_RULES=ON -DDETACH_KERNEL_DRIVER=ON when compiling driver, but i doesn't work.

I run these commands to install drivers:

Code: Select all

cd ~
git clone https://github.com/keenerd/rtl-sdr.git
cd rtl-sdr/
mkdir build
cd build
sudo make install
sudo ldconfig
cd ~
sudo cp ./rtl-sdr/rtl-sdr.rules /etc/udev/rules.d/
sudo reboot
How can I fix?

Site Admin
Posts: 2816
Joined: Mon Nov 19, 2012 11:54 pm

Re: I cannot enable bias tee

Post by rtlsdrblog » Fri Aug 30, 2019 11:39 am

Can you run rtl_test?

I'm not sure if Keenerds driver properly detaches the kernel driver.

Go here, https://www.rtl-sdr.com/rtl-sdr-quick-start-guide/, scroll to the bottom and try using the line to blacklist the kernel driver manually.

Post Reply