Page 1 of 1

Strong spurious signals - hardware or software issue?

Posted: Fri Jan 10, 2020 10:58 pm
by egeezer
Setup- SDR and upconverter are new:
Nooelectric SDR Smart using the telescoping antenna that came with the kit
Ham It Up Plus with upconverter switched on
Both powered by USB port on a Windows 10 PC
SDR#, offset -125000000 for upconverter

There are several strong spurious signals on the LW and MW bands that make the receiver pretty useless on the bands. When I tune the frequencies using my Teksun PL-880 receiver, the signals are not there, and I receive stations nicely. How do I determine whether it's the upconverter, NESDR Smart, SDR# or PC that's the cause?

Thanks for your help and suggestions!

I suspect it's either the SDR radio or upconverter, but not sure.
2020-01-10 17.35-Screenshot-151.jpg
Screen shot, the highest spikes are the spurious signals
2020-01-10 17.35-Screenshot-151.jpg (351.14 KiB) Viewed 2202 times

Re: Strong spurious signals - hardware or software issue?

Posted: Sun Jan 12, 2020 11:56 pm
by rtlsdrblog
Something certainly looks wrong there.

Can you try powering the upconverter with a battery to rule out interference from your PC?

Does the dongle work on standard broadcast FM reception?

What have you set the RF gain to?

Re: Strong spurious signals - hardware or software issue?

Posted: Tue Jan 14, 2020 5:20 pm
by Username
Yep that is noise and it might come from your Pc.

Re: Strong spurious signals - hardware or software issue?

Posted: Tue Jan 14, 2020 8:51 pm
by egeezer
First, thanks for the replies!

Yes, I did try powering the upconverter from a battery USB source. I also tried setting everything up on my laptop, same issues. The broadcast FM band works, but it's definitely not as sensitive as my Teksun PL-880, even when I set the telescoping antenna to the same length and location on the SDR as on my Teksun.

SDRSHARP has a lot of configuration options, and if you have any links to teaching a newbie what they are and how to use them, I'd be most appreciative. Ham radio has changed a lot since the '60s when a Drake 2B receiver and Collins AM/SSB/CW gear were the state of the art.

As a troubleshooting exercise, I'll try shutting off everything I can to see if it goes away, then power stuff back up one at a time to see what if anything changes.

Thanks again for helping out a new guy, and for any further suggestions you might have. I'll also post a support ticket to Nooelectric to see if they might exchange the devices or provide a firmware fix. I'll post replies here for reference by others who might encounter similar issues.

Re: Strong spurious signals - hardware or software issue?

Posted: Wed Jan 15, 2020 5:42 am
by rtlsdrblog
We have an SDR# guide at www.rtl-sdr.com/SDRSHARP.

Is the device running in Quadrature Sampling mode? Quadrature sampling is correct the mode for upconverters.