Page 1 of 1

SDR# does not recognize dongle

Posted: Sat Jul 25, 2020 10:12 pm
by RM59
Hi,

Despite numerous attempts to get my RTL-SDR working with SDR# I have not succeeded and urgently seek support from experts.

Hardware: Nooelec NESDR SMArt v4 RTL-SDR dongle (via Amazon).
Platform: Win10 Pro (x64/build 2004), dongle connected to port USB3.2 Gen 1, extension cable (to prevent blockage of adjacent USB-ports).
Software: SDR#, downloaded from AirSpy, v1.0.0.1732, installed on C:\ (unzipped, ran install-rtlsdr.bat), checked rtlsdr.dll in folder.
Driver: zadig.exe (run as administrator), v2.4 (build 721), installed driver WinUSB (v6.1.7600.16385) for Bulk-In, Interface (Interface 0).
Device Manager: Bulk-In, Interface listed under Universal Serial Bus devices (driver 6.1.7600.16385).

When I run SDR# at first instance it shows Device: 820T / Generic RTL2830U OEM (0) and Source: RTL-SDR (USB).
However, when the application is started (button) it returns: 'Cannot access RTL device'.
Next the Device has turned from 820T into Unknown.
Downloading RelWithDebInfo.zip, unpacking and running the x32 version of rtl_test.exe it return in a command window showing an extensive listing of messages: rtlsdr_demod_write_reg failed with -9 and rtlsdr_demod_read_reg failed with -9 (could not find what this means).

Rebooting the computer Device Manager under Universal Serial Bus controller now shows an Unknown USB Device (Device Descriptor Request Failed) which relates to Code 43.
Running SDR# now shows Device: E4000 / field empty and Source: RTL-SDR (USB).
When the application is started it retursn: 'No device selected'.

The above is corrected by unplugging/replugging the USB connection after which it returns as Bulk-In, Interface listed under Universal Serial Bus devices.
Running SDR# again results in the same sequence of events as described above.

Connecting it to another USB port or even an USB2.0 port does not make any difference.

Although I do not think the dongle is faulty it does feel more than warm.

I searched Google for hours trying to find tips or even solutions but have been unsuccessful so far.
Any feedback from the experts in this forum would be very much appreciated.


Kind regards,

René Meijn
Hoeven
The Netherlands

Re: SDR# does not recognize dongle

Posted: Sun Jul 26, 2020 4:33 pm
by Username
Did you fix it?

Re: SDR# does not recognize dongle

Posted: Sun Jul 26, 2020 5:34 pm
by RM59
No, unfortunately I have been unable to fix it and have given it a thought with currently three options left.
1
I could try and install it on a laptop and see whether the issue exhibits itself similarly; this would indicate a hardware issue with the USB from Nooelec.
2
Or I could try some other software; any suggestions welcome.
Ideally I would like to try some diagnostics for the USB as the messasges when running rtl_test.exe are incomprehensible for me.
3
Finally, I may take the chance of buying another RTL-SDR USB (preferably an "orginal" RTL-SDR v3).

Any suggestions or useful feedback would be welcome from the experts in this forum.
If only someone could tell me it is more than likely that the RTL-SDR Nooelec USB is faulty I would be directly going for option 3: buying a replacement.


Kind regards,

René Meijn
Hoeven
The Netherlands

Re: SDR# does not recognize dongle

Posted: Sun Jul 26, 2020 10:45 pm
by RM59
Problem solved!

Decided to eliminate the USB extension cable and plug directly into the port on the motherboard: success!
Apparently, the cable caused a critical voltage drop.
Read somewhere about the error messages when running rtl_test.exe ('rtlsdr_demod_write_reg failed with -9 and rtlsdr_demod_read_reg failed with -9') almost always having to do with USB power issues ....

Sincerely hope this topic/solution is helpful for many others experiencing similar issues.


Kind regards,

René Meijn
Hoeven
The Netherlands

Re: SDR# does not recognize dongle

Posted: Thu Jul 30, 2020 8:47 pm
by petrusev
Привет, спасибо за образцово-показательное изложение развлечения по установке. У меня тоже самое.
Отличие в - MSI.SDR Panadapter.
После zadig.exe в Диспетчере устройств появляется в устройствах USB: SDRplay (MSI.SDR):
"Устройство работает нормально", драйвер, реестр.
Но в событиях сказано: "Устройству USB\VID_1DF7&PID_2500\6&e3e7252&0&4 требуется дальнейшая установка." .
И дальше: "При запуске SDR # теперь отображается устройство: E4000 / поле пусто и источник: RTL-SDR (USB).
Когда приложение запускается, оно возвращает: «Устройство не выбрано/no device»" и т. д.
Кабель соединения проверен.
А теперь вопрос к "бывалым", если таковые есть: "...что делать и кто виноват? Железо или установка"
И простите за вопрос в формате ответа.
С уважением.
Сергей.