Page 1 of 1

Osmocom rtl-sdr drivers build error on MX Linux and Ubuntu

Posted: Sun Nov 01, 2020 7:56 pm
by mrkmpn
I haven't searched through the forums fully, so forgive me if this has already been posted, but I ran into this issue installing the drivers on both MX Linux 19.1 in virtualbox and Ubuntu 20.04 in WSL.

I followed this guide for installing the drivers: ... idev20.pdf

However, upon running the make command I was present with the error: /home/mark/rtl-sdr/rtl-sdr/src/librtlsdr.c:30:10: fatal error: libusb.h: No such file or directory
30 | #include <libusb.h>
| ^~~~~~~~~~

IF you get this error, run rm -rf from within the rtl-sdr/build directory and then run the following commands

sudo apt-get install pkg-config
and then
pkg-config --libs libusb-1.0
You should receive the output:

run make again, and it should succeed. Then continue the instructions provided in the tutorial. For step 6 to blacklist the default driver, rather than open the modprobe.d directory since you are already in command line, it is also easier to simply run:
sudo nano /etc/modprobe.d/blacklist-rtl.conf
enter blacklist dvb_usb_rtl28xxu
press ctrl + x to exit
press y and press enter to save

If you get the error again after running pkg-config, make sure you've emptied the build directory before running make again. I created this account to post this, because a quick google search only resulted in seeing a few other people frustrated with this issue. So I hope this helps anyone else that runs into this problem. I just wanted to get it up and running on linux to try out OP25.

Re: Osmocom rtl-sdr drivers build error on MX Linux and Ubuntu

Posted: Sat Jan 16, 2021 9:28 am
by zanco
Thums up for this one !

Ubuntu 18.04 in WSL with the same error, solved now !