Page 1 of 2

RTL SDR NOAA weather sat decoding

Posted: Wed Feb 03, 2021 8:31 pm
by helmdude
I have been using the RTL-SDR dongle and SDR# to capture NOAA satellite images for quite a while...example 1 below. I route the audio through the VB-audio Virtual cable into wxtoimg software.

However, recently the images have started to be unsync'd...example 2 below. The zigzagging is so bad that the software cant align it properly (I'm guessing)...looks really bad during the capture. I don't know if this was a windows update, driver update, etc. I have tried reinstalling SDR# and have even tried a newer version of SDR#. The "bad" image looks very similar to the images I used to get if the sample rate (in SDR#) was incorrect, but I have triple checked that.

Any help would be greatly appreciated!

Hardware/Software details:
RTL-SDR dongle V3
Antenna 3x3 CP yagi
SDR# V1.0.0.1732 and also tried 1784 (problem seemed worse in newer version)
2.4MSPS sample rate

Brian

December 2020 image
12101654_4.jpg
12101654_4.jpg (521.87 KiB) Viewed 1288 times
January 2021 image
12101654_4.jpg
12101654_4.jpg (521.87 KiB) Viewed 1288 times

Re: RTL SDR NOAA weather sat decoding

Posted: Thu Feb 04, 2021 1:53 pm
by helmdude
Another example of trying to capture image (NOAA 15). This is what it looks like during the capture.
noaa15_bad.jpg
noaa15_bad.jpg (37.53 KiB) Viewed 1243 times

Re: RTL SDR NOAA weather sat decoding

Posted: Thu Feb 04, 2021 3:50 pm
by helmdude
Also, I ran zadig again and verified the RTL-SDR driver...this is what is showing

I'm at my wits end here...
zadig.jpg
zadig.jpg (39.77 KiB) Viewed 1231 times

Re: RTL SDR NOAA weather sat decoding

Posted: Sat Feb 06, 2021 9:41 pm
by rjmura
had the same problem about 4 months ago, after over a year without any problems. can fix it by changing the audio sampling rate going into wxtoimg to 11025 Hz, as mentioned in its help file.
don't remember exactly what i did but i have the output of vb-audio virtual cable set to 11025 Hz in the vb control panel. also notice that in my windows sound settings, under device properties for vb-audio, advanced tab, the default format is set to 2 channel, 16 bit, 11025 Hz.

with the above settings, i can get good sync on wxtoimg using sdr#. however, sdr console still breaks up, whereas i used to have good results before. so there may be a problem in the way sdr console outputs its audio.

the big question is why the problem appeared after working so long? something happened, but i don't know what it is.

Re: RTL SDR NOAA weather sat decoding

Posted: Mon Feb 08, 2021 2:13 pm
by helmdude
I appreciate the reply...unfortunately, it still seems to have an issue...even with the settings you propose (see snapshot).

I just tried to capture N19
new_image_N19.jpg
new_image_N19.jpg (71.56 KiB) Viewed 1047 times

Re: RTL SDR NOAA weather sat decoding

Posted: Wed Feb 10, 2021 2:54 am
by rtlsdrblog
From the WXtoImg FAQ, is there any high CPU usage occuring during recording? https://wxtoimgrestored.xyz/faq/

Why is the image split (sometimes referred to as sync loss)?
The image looks as though it has been cut horizontally and the upper or lower portion shifted left or right. This may occur in just one place or in multiple places in the image.

Under Options, enable Resync which will correct most of these problems.

However it is best to minimise the occurrance of these splits in the first place. The problem is caused by other programs doing a lot of activity or using a lot of CPU or memory or performing a lot of disk i/o while WXtoImg is recording. Limiting the number and activity of other programs while WXtoImg is recording should eliminate the problem. Some screen savers can also cause this problem, so setting your screen saver to none would be a good idea.

Re: RTL SDR NOAA weather sat decoding

Posted: Thu Feb 11, 2021 1:38 pm
by helmdude
Thanks! I appreciate the help. Unfortunately, these things didn't solve the problem...I just tried N19 with sync/resync. I also closed every program that was running and looked at task manager while the program was running and nothing is taking CPU processing during the decode (at least not more than 1% from various windows processes). I also disabled screen saved...results look the same as I have been getting on every pass (see snapshot)...top image is without sync...bottom is rysync on.
resync.jpg
resync.jpg (39.65 KiB) Viewed 943 times

Re: RTL SDR NOAA weather sat decoding

Posted: Thu Feb 11, 2021 1:43 pm
by helmdude
From my understanding, Resync corrects for doppler type (constant) shifting?...not the random jjittery left-right loss of sync. I have played with this quite a bit and even run through the wxtoimg "calibration" which only corrects for a constant, gradual sync shift.

Re: RTL SDR NOAA weather sat decoding

Posted: Tue Feb 16, 2021 9:43 pm
by rjmura
try reinstalling wxtoimg, vb-audio, and sdr#. take down all your wxtoimg settings before you uninstall it.

Re: RTL SDR NOAA weather sat decoding

Posted: Mon Feb 22, 2021 6:40 pm
by helmdude
Thanks for the help...I tried this as well...however, What do you mean "take down all your wxtoimg settings before you uninstall it" ?
I did notice that wxtoimg retains some settings even after uninstalling. Do you know where these settings/config is located? I searched and cannot find it
By the way...wxtoimg won't run at all now that I have uninstalled and tried to reinstall, so I have a new problem now. It just hangs (unresponsive) when I open the program. I have tried uninstalling and reinstalling several times and deleting all references to the software as best I can, but I am probably missing the location of the "settings/config" file.