Page 1 of 3

Trouble installing SDR#

Posted: Sat Feb 06, 2021 6:01 am
by jncraig
This is a Windows 10, 64 bit, computer.

I downloaded and installed SDR# (SDRSharp) revision 1785 from airspycom tusing the QSG with no problem, until I go to open SDRSharp.exe. I get this error message: To run this application, you must install .NET.

I have verified that I have .NET Framework 4.8 installed. I also did the installations for dotnet-sdk-5.0.102-win-x64.exe and windowsdesktop-runtime-5.0.2-win-x64.exe. I did a Windows Update and my system is up to date. I have restarted the computer (more than) several times.

Can anyone suggest how to proceed?

Thanks,
Joe

Re: Trouble installing SDR#

Posted: Sat Feb 06, 2021 9:59 pm
by Joe_Q
I reinstalled SDRSharp today (on a computer where I have successfully run it in the past) and had the exact same error message, despite updating .NET. Something strange with this build of SDRSharp, I think.

Re: Trouble installing SDR#

Posted: Sat Feb 06, 2021 10:52 pm
by jncraig
I don't seem to be able to find an older build ...

Re: Trouble installing SDR#

Posted: Sat Feb 06, 2021 11:01 pm
by arraijan55
Install the x86 runtime I have the same problem the sdr# is in x88 not in the x64

Re: Trouble installing SDR#

Posted: Sun Feb 07, 2021 12:03 am
by feedthemonkey
I'm having the same experience on a machine that previously ran SDR# fine (I did a clean Windows 10 install to fix unrelated issues a week ago).

I confirm in registry editor that I'm running .NET 4.8.04084

I get the window asking me to install the .NET Framework. ...If I follow through and install both x64 and x86 (I'm a 64-bit machine, but installing ONLY x64 will not clear the error) I can open the program, but I do NOT get the option of RTL-SDR (USB) as a source.

Re: Trouble installing SDR#

Posted: Sun Feb 07, 2021 1:00 am
by martinoized
I have exactly the same problem. Already had .NET on Windows 10. SDR# says it needs it and prompts to download .NET 5.0. I do that and it still doesn't start. Where does .NET 5.0 come from? I didn't think .NET had version > 4.8.
I looked at configuration file and it says nothing about .NET. Dead in the water right now. :-(

Re: Trouble installing SDR#

Posted: Sun Feb 07, 2021 1:36 am
by jncraig
I installed X-86 version of the runtime and I can now open SDR#..

Source doesn't give me a choice of RTL-SDR (USB). Then I plugged the dongle into another USB port and it seems to be working ...

Re: Trouble installing SDR#

Posted: Sun Feb 07, 2021 1:42 am
by martinoized
I've browsed around the forum didn't see anything similar to this. I wonder if it's a bad build or something? A real showstopper of a problem and I'm not that familiar with .NET.

Re: Trouble installing SDR#

Posted: Sun Feb 07, 2021 2:12 am
by jncraig
The key for me was the x86 version of the runtime.

Secondary issue was getting the dongle into a different USB port.

Re: Trouble installing SDR#

Posted: Sun Feb 07, 2021 2:55 am
by feedthemonkey
Thanks, jncraig for the idea about trying another USB port. I tried 2 others, but no luck getting "RTL-SDR (USB)"

also, I'll note that when I X-out the app, I get this message:

"unhandled exception has occurred in your application...blah blah blah.. Access to the path 'C:\Windows\system32\SDRSharp.layout.xml' is denied"