rtl_tcp tuner agc problem in android, but not in windows

Need help installing or figuring out something about your SDR? Ask here.
Post Reply
Posts: 1
Joined: Fri Apr 23, 2021 7:17 am

rtl_tcp tuner agc problem in android, but not in windows

Post by AlexAT » Fri Apr 23, 2021 10:57 am

I have set up a Raspberry Pi 3+ with two USB-Dongles.
One of them is a NooElec NESDR SMArt XTR with the E4000 chip.
This dongle is used by rtl_tcp and when I open SDRConsole, or SDR# in Windows, it works fine. All I have to do is turn on Tuner-AGC and I have perfect reception.

However, when I connect with my Android phone, I have only noise. I tried RF Analyzer, MagicSDR and SDRTouch.
It doesn't matter what I do with the gain settings in those apps.

The weird thing:
If I first connect from my Windows machine and turn on Tuner AGC, the dongle starts to work properly.
Then I shut down the Application in Win and connect with any Android app to the same tcp-server.
In this situation, it also works on Android and the gain-settings do their jobs.

It seems that the Windows application does something to the dongle, that the Android app does not. And whatever it is, it remains in this state for a while. On the next day, it does not work anymore until I start with Win again.
Even after a reboot and complete shutdown the dongle still works fine, once it's "prepared".

Does anybody have an idea what could cause this behaviour?
I tried to set fixed gain settings (g 0 and -g 42) for rtl_tcp but that has no effect.
There are no error messages and I haven't found any way to fix this problem from the command line on the raspberry.

Output of rtl_test -t:

Found 2 device(s):
0: Realtek, RTL2838UHIDIR, SN: 4000
1: Realtek, RTL2838UHIDIR, SN: 820

Using device 0: Generic RTL2832U OEM
Found Elonics E4000 tuner
Supported gain values (14): -1.0 1.5 4.0 6.5 9.0 11.5 14.0 16.5 19.0 21.5 24.0 29.0 34.0 42.0
Sampling at 2048000 S/s.
Benchmarking E4000 PLL...
[E4K] PLL not locked for 51000000 Hz!
[E4K] PLL not locked for 2179000000 Hz!
[E4K] PLL not locked for 1090000000 Hz!
[E4K] PLL not locked for 1257000000 Hz!
E4K range: 52 to 2178 MHz
E4K L-band gap: 1090 to 1257 MHz

Site Admin
Posts: 2913
Joined: Mon Nov 19, 2012 11:54 pm

Re: rtl_tcp tuner agc problem in android, but not in windows

Post by rtlsdrblog » Mon May 10, 2021 4:10 am

With the E4000 you need to activate offset tuning for it to work properly. There should be a setting in the Android app.

Post Reply