Setting the KerberosSDR EEPROM

Discuss KerberosSDR - 4x Coherent RTL-SDR
rtlsdrblog
Site Admin
Posts: 2191
Joined: Mon Nov 19, 2012 11:54 pm

Re: Setting the KerberosSDR EEPROM

Post by rtlsdrblog » Sun May 12, 2019 5:33 am

StandingWave wrote:
Sat May 11, 2019 10:37 am
OK, so I plugged in the KDSR for the first time, the Generic RTL drivers (for all four RTL-SDR's) installed just fine on Win7/64bit - I see four RTL2832U devices on my Device Manager, but when I run rtl_eeprom.exe (x64) just for a quick overview on what's the status on KSDR, without reading or writing anything into the eeprom, I get this message:

Code: Select all

\...rtl-sdr-release\x64>rtl_eeprom.exe

Found 4 device(s):
  0:  Generic RTL2832U
  1:  Generic RTL2832U
  2:  Generic RTL2832U
  3:  Generic RTL2832U

Using device 0: Generic RTL2832U
usb_open error -12
Failed to open rtlsdr device #0.
In comparison, when I changed the S/N on my RTL-SDR USB dongle with the same software and computer (I have no SDR units at all plugged into this PC, and I used this same rig to rewrite a RTL-SDR firmware, that worked just fine).

Troubleshoot, Ignore, Abort, Retry?

Any ideas?

Thanks.
Are you powering the KSDR correctly?

StandingWave
Posts: 29
Joined: Fri Jul 27, 2018 1:00 am

Re: Setting the KerberosSDR EEPROM

Post by StandingWave » Sun May 12, 2019 3:51 pm

rtlsdrblog wrote:
Sun May 12, 2019 5:33 am
Are you powering the KSDR correctly?
Hmm, I'm using a Belkin USB distributor that's 5V @ 2.4A (it's an AC+USB outlet combo). In addition, the device is plugged to my PC's USB3 port via the USB data connection. I tried switching the USB bus power to another USB socket on my PC, but that didn't help out either. Will have to look into where I could find a proper high-amp USB3 power source here in northern EU. Will try to find one and report back if there was any success ....

Cheers!

StandingWave
Posts: 29
Joined: Fri Jul 27, 2018 1:00 am

Re: Setting the KerberosSDR EEPROM

Post by StandingWave » Sun May 12, 2019 5:34 pm

Also, I'd need to ask what would be a suitable USB power source, i.e. would this one from Belkin be appropriate for the KSDR? I just looked into this model, and it has received only good reviews from its users: https://www.belkin.com/us/p/P-F8M990/
At a Glance:

Universal compatibility
4 USB ports
10 ft. cable
5.4A power
Automatic power adjust for connected devices
Wall-mountable
Elegant design
The bottom line being the highlighted row - is having a USB power source with automatic power adjust such as in the example model above bad idea with the KSDR? Belkin does make otherwise some decent stuff ...

StandingWave
Posts: 29
Joined: Fri Jul 27, 2018 1:00 am

Re: Setting the KerberosSDR EEPROM

Post by StandingWave » Sun May 12, 2019 8:27 pm

OK, so the previous power source I used was a Belkin's AC power distributor with USB ports in it, it was rated at 5V / 2.4 A max output power, no dice. I tried another PSU just now that's rated @5V that had a lower amp rating and that did not change the outcome with rtl_eeprom.exe.

Again, out of the available documentation (which is the product page for KSDR and some of the blog & forum posts here at rtl-sdr.com), is it nowhere properly and clearly stated what kind of PSU apart from the 5V voltage you should be using to power up the KSDR through the USB-C port. It says "that can handle up to 3A"; but on one of the threads over here somebody said that if you're running the KSDR on 5V instead of 4.5V, the amp requirements should be lower ... Sheesh!

The blue LED inside the KSDR (which is not properly explained either) does light up when I connect the USB-C cable in addition to the MicroUSB data transfer cable, that should be an indicator that at least it's getting powered, right?

Code: Select all

...\rtl-sdr-release\x64>rtl_eeprom.exe
Found 4 device(s):
  0:  Generic RTL2832U
  1:  Generic RTL2832U
  2:  Generic RTL2832U
  3:  Generic RTL2832U

Using device 0: Generic RTL2832U
Found Rafael Micro R820T tuner

Current configuration:
Error: invalid RTL2832 EEPROM header!
Error: invalid string descriptor!
Error: invalid string descriptor!
Error: invalid string descriptor!
__________________________________________
Vendor ID:              0xffff
Product ID:             0xffff
Manufacturer:                                                                  
                                                                   t☼
Product:
Serial number:
Serial number enabled:  no
IR endpoint enabled:    yes
Remote wakeup enabled:  yes
__________________________________________
What I DID find upon searching that particular error message though, was i.e. the rtlsdrblog GitHub issue that's been open since April 3., apparently it's quite easy to brick your KSDR. See the issue titled "safety catch" for rtl_eeprom #2: https://github.com/rtlsdrblog/rtl-sdr-kerberos/issues/2

Seriously, guys. What gives? I'm not the first nor the only one voicing my opinion on the fact that there needs to be a bit better documentation for the board. And that's with all due respect. You're doing an awesome job and I've been your long-time supporter, but seriously. Can we get this wagon rolling on, please?

[EDIT: I will try to run the rtl_eeprom on my Raspberry Pi 3B+ and see what it says then. Will post the results.]

StandingWave
Posts: 29
Joined: Fri Jul 27, 2018 1:00 am

Re: Setting the KerberosSDR EEPROM

Post by StandingWave » Sun May 12, 2019 9:08 pm

OK, so after running KSDR on the Raspberry Pi 3B+ pre-built image from RTL-SDR, the status window in the KerberosSDR util seems to show a green light for the power status in the program window as I try running the simple routines on it.

With rtl_eeprom, I get the "same-kindish" warning as on the Win7/64bit PC:

Code: Select all

[email protected]:~ $ rtl_eeprom
Found 4 device(s):
  0:  Generic RTL2832U
  1:  Generic RTL2832U
  2:  Generic RTL2832U
  3:  Generic RTL2832U
 
Using device 0: Generic RTL2832U
rtlsdr_write_reg failed with -9
rtlsdr_demod_read_reg failed with -7
rtlsdr_demod_write_reg failed with -9
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
r82xx_write: i2c wr failed=-1 reg=1a len=1
r82xx_init: failed=-1
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
 
No EEPROM has been found.
I'm not sure what the other error messages are, but the GitHub "safety catch" issue at https://github.com/rtlsdrblog/rtl-sdr-kerberos/issues/2 seems to suggest that by default, the rtl_eeprom util should show an error message for the EEPROM, since there is none on the board when it's shipped out. Am I on the right track or have I completely lost my mind already?

I'd assume it'd be the safest bet to run the rtl_eeprom flash procedure on a a RPI3B+ rather than in Win7/64bit admin prompt, as it's the latest version of the KSDR's pre-built Raspbian image and all, but ...

StandingWave
Posts: 29
Joined: Fri Jul 27, 2018 1:00 am

Re: Setting the KerberosSDR EEPROM

Post by StandingWave » Sun May 12, 2019 10:13 pm

Found the culprit! I can't believe it, a brand new USB3.1 USB-C cable, probably less than ten times plugged in and out, straight from the box and *sha-zang*! The USB-C connector end came off when I unplugged it from the KSDR. :lol: :x :oops:

Luckily I was so hindsighted with the common non-existent quality control of today's world that I had bought two cables. So, all's well for now what comes to the KSDR EEPROM flashing. Did it on the Raspi3B+ box and gave 0 phuq'ues about the warnings, everything went as smooth as F.

Used the instructions as advised by rtl-sdr's initial post + the additions noted by user kb3cs.

1. Enabled all the DIP switches by switching all four to ON position.
2. Ran rtl_eeprom from the KSDR Raspbian pre-built image for Raspberry Pi Model 3B+

First batch of code:

Code: Select all

rtl_eeprom -d 0 -g realtek_oem
rtl_eeprom -d 1 -g realtek_oem
rtl_eeprom -d 2 -g realtek_oem
rtl_eeprom -d 3 -g realtek_oem
^ Power cycle (as suggested by rtl_eeprom after each flash) between each step in the above, just to be safe.

Second batch of code, ran them just one by one and then power cycled the device, worked just fine:

Code: Select all

rtl_eeprom -d 0 -s "001" -m RTL-SDR -p KerberosSDR
rtl_eeprom -d 1 -s "002" -m RTL-SDR -p KerberosSDR
rtl_eeprom -d 2 -s "003" -m RTL-SDR -p KerberosSDR
rtl_eeprom -d 3 -s "004" -m RTL-SDR -p KerberosSDR
Huge thanks to the forum mods & devs for listening me whine and username kb3cs for the additional heads up on adding the identification signature into KerberosSDR. You might want to change the official instructions on the initial post onto this thread to match that one.

Why? Well, upon my initial configuration, I noticed that actually having a RTL-SDR dongle running alongside with just one KerberosSDR's receiver unit at the same time will cause SDR software confusion. That's a real good catch on how to avoid any issues.

Also, my idea on this subject matter would be to perhaps have a simple script added to the official KSDR build so that you could quickly flash the unit to the recommended/desired EEPROM settings.

Thanks.

StandingWave
Posts: 29
Joined: Fri Jul 27, 2018 1:00 am

Re: Setting the KerberosSDR EEPROM

Post by StandingWave » Thu May 16, 2019 1:32 pm

Just a quick update:

After successfully flashing the EEPROM, I've got the unit to work with both my Win7/64bit and my RPi3B+ boxes. However, using multiple tuners (starting from just 2 out of the 4 in KSDR), i.e. with SDR-Console v3 on Win7/64bit, causes the playback to be intermittent.

That happens even with just two of the built-in RTL-SDR's of the KerberosSDR enabled. I don't experience the same kind of "on-off-tremolo-like-stutter" in the audio when I'm using two separate RTL-SDR USB dongle sticks with the same exact setup, even with higher sample frequencies.

Could that be because of some kind of a driver issue? With 2 x RTL-SDR dongles into separate USB 3.0 ports of my Win7 desktop PC vs. 1x KerberosSDR with just two out of the four radios enabled attached to a single USB3.0 lane, I'm thinking of USB data flow or other bottlenecks causing the audio signal clutter or something to that degree. Any ideas where I should begin my hunt?

User avatar
kb3cs
Posts: 34
Joined: Thu Apr 04, 2019 2:15 pm

Re: Setting the KerberosSDR EEPROM

Post by kb3cs » Thu May 16, 2019 2:35 pm

as this thread is intended for all thing EEPROM, please refer to my reply to your duplicate post in your other thread. :)
Last edited by kb3cs on Fri May 17, 2019 1:31 am, edited 1 time in total.

StandingWave
Posts: 29
Joined: Fri Jul 27, 2018 1:00 am

Re: Setting the KerberosSDR EEPROM

Post by StandingWave » Fri May 17, 2019 1:19 am

kb3cs wrote:
Thu May 16, 2019 2:35 pm
as this thread is intended for all thing EEPROM, please refer my reply to your duplicate post in your other thread. :)
Ah, pardon me, I'm sorry for the tangent. I thought I had that frequency lock on in my mind before I started my ramblin', but that's the way it sometimes goes, hehe. ;)

I'm still having issues with the unit, but I'll post those on the other threads on the KSDR subject.

Back to topic, the EEPROM flash instructions I gave seemed to have worked out quite OK, I think the rest of the issues I'm experiencing are somewhere else in the overall hardware chain (probably includes me as well, hehe). Thanks for the help and I hope my babbles on that issue were of help to someone struggling with the same ordeal.

Cheers!

jojo
Posts: 1
Joined: Fri Mar 15, 2019 4:54 pm

Re: Setting the KerberosSDR EEPROM

Post by jojo » Sun Jun 23, 2019 8:39 pm

This is a dangeroes way
it kills one of the 4 sdr's inside
The only one give now usb id: FFFF FFFF 00
and is not accessible

is there a solution

Regards Joan
Edit:OK fixit with a Raspberry with linux

Post Reply