Page 1 of 1

Single radio failure on my KSDR?

Posted: Wed Jun 19, 2019 4:36 pm
by lukestuts
Hello, this is my first post on the rtl-sdr.com forums!

I received my KerberosSDR about a month ago and I have been having a great time learning about RDF and SDR.

However, it looks like the first radio has developed a fault.

I can see the blue light for radio 1 come on when I set the DIP switch, but it no longer appears as a USB device (using lsusb).

There is no problem with the other three radios.

I have tried it on my Ubuntu PC and my laptop but radio 1 doesn't come up on either device.

I have visually inspected the PCB but I can't see any obvious faults with components.

Has anyone had a similar issue, or can anyone suggest fault-finding or repair steps? I would be very grateful for any assistance!

Re: Single radio failure on my KSDR?

Posted: Fri Jun 21, 2019 5:22 am
by rtlsdrblog
Hey please contact us at [email protected] and [email protected] for a return + replacement if one unit has failed and nothing works to get it back.

Could it be a faulty DIP switch? If you wiggle the #1 DIP switch around, does the light flicker?

Re: Single radio failure on my KSDR?

Posted: Sun Jun 23, 2019 2:06 pm
by lukestuts
Thank you for your reply!

I bought two so I am still able to continue my project.

I have given the DIP switches a couple of toggles. I don't think this is the problem because the DIP switch for the first radio correctly toggles the blue LED for that radio.

I don't really have the knowledge to locate the exact component that has failed. I will try wiggling and see if the light flickers.

If it still does not work next week, I will email as advised. Thanks again!