Page 1 of 1

hydra_main_window.py is empty

Posted: Sun Oct 13, 2019 2:26 pm
by nikuss
Hi everyone.

I tried start ./run.sh in my ubuntu 18.04.3 LTS, the software is running ok, but the window of kerberos setup is empty, i need to calibrate in my smartphone because I see anything in kerberos window...

Someone could help me? I dont know what is wrong.

thank you
Captura de pantalla de 2019-10-13 16-25-30.png
Capture of the window
Captura de pantalla de 2019-10-13 16-25-30.png (217.79 KiB) Viewed 527 times

Re: hydra_main_window.py is empty

Posted: Sun Oct 13, 2019 6:51 pm
by myke
After installing KerberosSDR did you first run setup_init.sh ? It will chmod and assign execution to selected files.

Re: hydra_main_window.py is empty

Posted: Sun Oct 13, 2019 8:46 pm
by nikuss
Yeah, I start setup_init.sh and It finished without a problem... Is It possible that It have a wrong setup_init.sh configuration?
Thank you ;)

Re: hydra_main_window.py is empty

Posted: Mon Oct 14, 2019 12:13 am
by myke
Are you connected to a KerberosSDR? In order to test Driver installation - Have you opened a terminal and tested each of the radios? (test before starting program)
At this stage we recommend first testing your four tuners with rtl_test. Open four terminal windows, or tabs, and in each window run "rtl_test -d 0", "rtl_test -d 1", "rtl_test -d 2" and "rtl_test -d 3". Ensure that each unit connects and displays no errors. Install KerberosSDR Demo Software[/code]
Next I would check the results you get according to instructed troubleshooting step: (actually &>log_python& - I've had no reason to check for that log. I will fire mine up tomorrow and take a look for log_python - but removing '&>log_python&' should result in errors to the terminal)
TROUBLESHOOTING:

Edit the run.sh file and comment out the >&/dev/null parts on the last line to show any errors to the terminal.

Re: hydra_main_window.py is empty

Posted: Mon Oct 14, 2019 1:04 am
by ckoval7
The only thing I could think of is maybe you're missing some QT libraries. QT is a huge set of individual packages, and it's not unusual to miss one or two when trying to install them all. Also, make sure all your python3 stuff is up to date.

Re: hydra_main_window.py is empty

Posted: Mon Oct 14, 2019 9:11 am
by nikuss
Thank you guys.
I have installed QT libraries and I updated and upgraded... I tested all RTL,s without problems, I run in order all the quick start guide but it doesn't works... :(
I don't know why it doesn't works, that files are my run.sh and my setup_init.sh tell me what's your opinion

thank you again :)

Re: hydra_main_window.py is empty

Posted: Mon Oct 14, 2019 9:13 am
by nikuss
The other impr pant

Re: hydra_main_window.py is empty

Posted: Mon Oct 14, 2019 11:55 am
by ckoval7
What is the content of log_python?
Close the main window, then do:

Code: Select all

cat log_python
That file will be empty until the main window is closed.

Optionally, you can remove &>log_python from the run.sh file. That will print any python output to the terminal.

Another note, you'll want to change "IPADDR" to the IP address of your machine in run.sh. That won't help with the current problem, but you'll need it to see the graphs in the web UI once everything is working.