Page 1 of 1

Problems starting processing

Posted: Sat Jan 11, 2020 12:05 pm
by cowboymonkey
Hi all,

Trying to set up the KSDR on a Ubuntu machine, software and libraries are installed as per instructions, and have compiled everything without issues.
I've enabled logging via, but there are only good messages in the four logfiles, everything seems to be running. The only hint I have right now, is that from dmesg I can see that rtl_daq segfaults:

rtl_daq[26824]: segfault at 90 ip 00007f911b8ec860 sp 00007f9118eb1ec8 error 4 in[7f911

I seem to have managed to mis-read instructions on the eeprom thread, mangling the first device (it seems) im waiting for a reply on how to fix that, in order to have al four radios available again.

So..Im not really sure what to try now. Is it possible to get the software running, even though three radios is not enough for the fun stuff?

Edit: I have high quality cables and powersupply for the KSDR - all four radios were working with rtl_test simultaneously, before I mangled the eeprom on the first device :/

Edit #2: I've edited this post like five times now, sorry! :-)

Re: Problems starting processing

Posted: Mon Jan 13, 2020 12:06 am
by rtlsdrblog
Can you give more info about what you did to mangle the EEPROM, and what the exact problem with the EEPROM is now? What does rtl_test show?

The code is not going to work without all 4 devices running.

Re: Problems starting processing

Posted: Mon Jan 13, 2020 11:55 am
by cowboymonkey

Thank you for getting back to me! :-)

After I initially couldnt make it work, I tried the rtl_eeprom command on viewtopic.php?f=9&t=4679&start=10#p11170 as I speculated that it maybe was looking for a specific VID/PID that wasnt pre-programmed. After that, I located the segfault in the thinking that the segfault may be the actual reason why its not working.

I'd like to try and replicate the problem on my RPi3b, but without one of the radios fully functional, its probably not worth the trouble yet.

At the bottom of the page I referred to, someone warns of a "soft bricking" of the radios (this post: viewtopic.php?f=9&t=4679&start=10#p11487 ) - im seeing the "FFFF" for VID/PID in syslog. But he also says that he fixed it - he just didnt write how... :-) Im unable to see the radio with rtl_test and rtl_eeprom. Any suggestions...?

Re: Problems starting processing

Posted: Tue Jan 14, 2020 3:24 am
by rtlsdrblog
If the exact commands were used, the only way to brick it that I can see would be to remove power or disconnect the unit while it was writing to the EEPROM.

If it's corrupt you should just be able to run rtl_eeprom again to rewrite it.

What does rtl_test show you?

Re: Problems starting processing

Posted: Tue Jan 14, 2020 1:54 pm
by cowboymonkey
Yeah, I was a bit surprised as well.

The rtl_test only shows the three remaining devices. When I disable all other devices it just doesnt show up in the utility. It shows up in dmesg like this:

Code: Select all

Jan 13 12:53:31 v kernel: [ 1855.889084] usb 2-2.5: New USB device found, idVendor=ffff, idProduct=ffff
Jan 13 12:53:31 machine kernel: [ 1855.889090] usb 2-2.5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Jan 13 12:53:31 machine kernel: [ 1855.889093] usb 2-2.5: Product: KerberosSDR
Jan 13 12:53:31 machine kernel: [ 1855.889096] usb 2-2.5: Manufacturer: RTL-SDR
Jan 13 12:53:31 machine kernel: [ 1855.889099] usb 2-2.5: SerialNumber: 001
WHen that device is the only one enabled, I am unable to use rtl_test on it and/or other rtlsdr utilities - not sure if I should be able to?

Other rtlsdr-devices I have are still working, if that helps.

Re: Problems starting processing

Posted: Wed Jan 15, 2020 5:24 am
by rtlsdrblog
Okay looks like the PID and VID of your device is mangled as it's showing idVendor=ffff, idProduct=ffff for some reason.

Can you try and clone a fresh version of rtl-sdr-kerberos? I've just made a simple update that should allow you to access that device. Go through the standard make and sudo make install, then run sudo ldconfig.

Once installed if you try to run rtl_test, rtl_eeprom etc, you'll probably get udev rules errors due to the bungled EEPROM device, so run the rtl_eeprom command with sudo.

So, as your bungled device is serial #1, try this command to fix it:

Code: Select all

sudo rtl_eeprom -d 1 -g realtek_oem

Re: Problems starting processing

Posted: Wed Jan 15, 2020 4:15 pm
by cowboymonkey
Hi again!

Your updated c-file works :-)

This is the output of rtl_test:

Code: Select all

# rtl_test
Found 4 device(s):
 0:  RTL-SDR, KerberosSDR, SN: 001
  1:  Generic, RTL2832U, SN: 77771111153705700
  2:  Generic, RTL2832U, SN: 77771111153705700
  3:  Generic, RTL2832U, SN: 77771111153705700
Should I still go ahead and run the rtl_eeprom command or...? It seems that I dont need to rename them to run the software?

Update: I've run the KerberosSDR software with success! Now, on to test with the RPi3B - and to see how to sync and all that. Excellent!

Re: Problems starting processing

Posted: Thu Jan 16, 2020 7:55 am
by rtlsdrblog

Still best to correct the EEPROM if you ever want to use it without our software, just run the eeprom commands again to reset it to realtek_oem, then write the Kerberos serial.

Re: Problems starting processing

Posted: Mon Jan 27, 2020 10:00 am
by cowboymonkey
Hi again,

So - I did not get around to the actual rtl_eeprom command as I expected it to work - hint - it didnt hehe, sorry for the long wait! rtl_test works just fine, but rtl_eeprom doesnt play along:

Code: Select all

# rtl_eeprom -d 1 -g realtek_oem
Found 1 device(s):
  0:  Generic RTL2832U

Using device 1: 
Failed to open rtlsdr device #1.
Not sure how to proceed with this? :-) Thank you so much so far for the help!

Re: Problems starting processing

Posted: Tue Jan 28, 2020 3:12 am
by rtlsdrblog
Looks like you're doing the method where you have turned off all the other units via the DIP switch? In that case you need to set the device number flag to zero, "-d 0". You can see that it's labelled as device zero

Found 1 device(s):
0: Generic RTL2832U