SDR# crashes when starting to record "Baseband"

Need help installing or figuring out something about your SDR? Ask here.
Post Reply
Posts: 2
Joined: Wed Apr 03, 2019 1:57 pm

SDR# crashes when starting to record "Baseband"

Post by phoebus » Wed Apr 03, 2019 2:13 pm


I have problems with the recording function of SDR#. Every time I start recording a file with the option “Baseband” activated SDR# crashes.

  • Background:
I work at a project where I have a Raspberry Pi connected to a RTL-SDR-dongle (R820T) and a directional antenna to receive pulsating transmitter signals of 150.054 MHz. The Raspberry sends the signals via Wlan to a laptop, where I want to make several 20-seconds-recordings with SDR#.

The transmission works fine. I receive the signals via the source RTL-SDR (TCP). I can make recordings with the option “Audio” selected in the recording tab. The audio files are saved.

  • Problem:

The problem starts when I change the option “Audio” to “Baseband” in the Recording tab. Every time I press the “record” button to start a 8-Bit-PCM record, SDR# terminates after 0-1 seconds without an error message. It just closes.

The crash.txt file contains only this. I am not sure if this crash report even relates to my actual problem. I attached it anyway:

Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.
at SDRSharp.WavRecorder.dll.SimpleRecorder.DiskWriterThread (IL offset: 0xbd)
at mscorlib.dll.ThreadHelper.ThreadStart_Context (IL offset: 0x14)
at mscorlib.dll.ExecutionContext.RunInternal (IL offset: 0x79)
at mscorlib.dll.ExecutionContext.Run (IL offset: 0x0)
at mscorlib.dll.ExecutionContext.Run (IL offset: 0x2b)
at mscorlib.dll.ThreadHelper.ThreadStart (IL offset: 0x8)

  • Hardware:

Laptop: Win10 Home, CPU Intel Core i7-6500U 2.5GHz, RAM 8GB, 64bit
RTL-SDR-dongle: R820T

  • Settings:

see attachments

  • Steps that I've already done:

- Reduce the sample rate, down to the lowest value of 0.25 MSPS
- Turn off “Correct IQ”
- Reduce “Order”, down to 100
- Turn off “Unity Gain”
- Copy the whole SDR# folder to another disc (from a HDD to a SSD)

Do you have any suggestions how I can try to solve the problem?
Thank you much for your help!
SDR_Settings.jpg (382.87 KiB) Viewed 1609 times
Unbenannt.JPG (19.28 KiB) Viewed 1609 times

Site Admin
Posts: 2677
Joined: Mon Nov 19, 2012 11:54 pm

Re: SDR# crashes when starting to record "Baseband"

Post by rtlsdrblog » Thu Apr 04, 2019 12:28 am

Double check that the SDR# folder has permissions to write.

If it's not that i'd also try reinstalling the .NET runtimes.

Failing all that, you'll probably need to ask the dev on the SDR#/Airspy group

Posts: 2
Joined: Wed Apr 03, 2019 1:57 pm

Re: SDR# crashes when starting to record "Baseband"

Post by phoebus » Tue May 21, 2019 4:37 pm

Thank you for the answer!

The folder had writing permissions. I think I managed to reinstall the runtimes (but I'm not sure about that :D ).
It didn't change the problem. Sometimes recording baseband even worked. But trying it again with exactly the same settings made sdrsharp close again.

I changed to another recording plugin which worked fine, so the problem is not mine anymore.

Post Reply