Strange USB problems

Discuss KerberosSDR - 4x Coherent RTL-SDR
Post Reply
dl9cat
Posts: 2
Joined: Mon Jul 15, 2019 6:55 pm

Strange USB problems

Post by dl9cat » Mon Jul 15, 2019 7:27 pm

I have problems with USB ports on my KerberosSDR.

Power comes from a powerbank via USB-C, the micro USB is connected with a 80cm cable to the PC. The micro USB port works with the right cable. Because 80cm is too less I tried to use 3m USB extension cables for data. But one I had is not stable, the connection stalls after a short time and sometimes I even don´t get a connection:

[ 128.815754] usb 1-10: new high-speed USB device number 13 using xhci_hcd
[ 128.963739] usb 1-10: New USB device found, idVendor=0424, idProduct=2517
[ 128.963745] usb 1-10: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[ 128.964582] hub 1-10:1.0: USB hub found
[ 128.964618] hub 1-10:1.0: 7 ports detected
[ 129.251578] usb 1-10.2: new high-speed USB device number 14 using xhci_hcd
[ 129.363542] usb 1-10.2: New USB device found, idVendor=0bda, idProduct=2832
[ 129.363548] usb 1-10.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 129.363552] usb 1-10.2: Product: RTL2832U
[ 129.363556] usb 1-10.2: Manufacturer: Generic
[ 129.363560] usb 1-10.2: SerialNumber: 77771111153705700
[ 129.451639] usb 1-10.3: new high-speed USB device number 15 using xhci_hcd
[ 129.564404] usb 1-10.3: New USB device found, idVendor=0bda, idProduct=2832
[ 129.564410] usb 1-10.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 129.564414] usb 1-10.3: Product: RTL2832U
[ 129.564418] usb 1-10.3: Manufacturer: Generic
[ 129.564422] usb 1-10.3: SerialNumber: 77771111153705700
[ 129.651745] usb 1-10.4: new high-speed USB device number 16 using xhci_hcd
[ 129.740363] usb 1-10.4: Device not responding to setup address.
[ 129.979945] usb 1-10.4: New USB device found, idVendor=0bda, idProduct=2832
[ 129.979951] usb 1-10.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 129.979956] usb 1-10.4: Product: RTL2832U
[ 129.979960] usb 1-10.4: Manufacturer: Generic
[ 129.979963] usb 1-10.4: SerialNumber: 77771111153705700
[ 130.063537] usb 1-10.5: new high-speed USB device number 17 using xhci_hcd
[ 130.180268] usb 1-10.5: New USB device found, idVendor=0bda, idProduct=2832
[ 130.180274] usb 1-10.5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 130.180279] usb 1-10.5: Product: RTL2832U
[ 130.180283] usb 1-10.5: Manufacturer: Generic
[ 130.180286] usb 1-10.5: SerialNumber: 77771111153705700
[ 135.800055] tee (3316): drop_caches: 3

So I bought a new high quality cable which has significantly less voltage drop. But this makes it worse, I get errors and lsusb does not show any of the four devices.

[ 334.380228] usb 1-10: new high-speed USB device number 30 using xhci_hcd
[ 334.508402] usb 1-10: device descriptor read/64, error -71
[ 334.744265] usb 1-10: device descriptor read/64, error -71
[ 334.980419] usb 1-10: new high-speed USB device number 31 using xhci_hcd
[ 335.108245] usb 1-10: device descriptor read/64, error -71
[ 335.344190] usb 1-10: device descriptor read/64, error -71

The cables itself work with my RTL-SDR BLOG V.3 without any problems. Before my KerberosSDR arrived I had the possibility to test another device, this worked without any problems with the first USB extension. Any suggestions what to do?

regards
DL9CAT

rtlsdrblog
Site Admin
Posts: 2265
Joined: Mon Nov 19, 2012 11:54 pm

Re: Strange USB problems

Post by rtlsdrblog » Tue Jul 16, 2019 9:55 am

To confirm, it's working normally with the 80cm cable, just not with the 3M one?

3M might unfortunately be too long to sustain such a high data rate.

Stromeko
Posts: 15
Joined: Wed May 01, 2019 6:32 pm

Re: Strange USB problems

Post by Stromeko » Tue Jul 16, 2019 5:50 pm

If you power the unit via USB-C, then there shouldn't be any appreciable voltage drop on the USB connection to the PC. If you specifically bought a "long USB cable with low voltage drop", then chances are it's meant for charging only and has never been tested with actual high-speed USB communication. Avoid extension cables, the extra connectors will produce problems eventually even when they initially appear to work fine.

dl9cat
Posts: 2
Joined: Mon Jul 15, 2019 6:55 pm

Re: Strange USB problems

Post by dl9cat » Wed Jul 17, 2019 8:44 pm

Things get even more strange:

Setup for all:
Power from USB Powersupply into USB-C port.

Cable connections:

PC - 80cm uUSB cable - Kerberossdr => Working

PC - old 3m USB extension - 80cm uUSB cable - Kerberossdr => Not Working today. Yesterday it worked...
PC - new 3m USB extension - 80cm uUSB cable - Kerberossdr => Not Working
PC - old 3m USB extension - RTL-SDR Blog V3 => Working
PC - new 3m USB extension - RTL-SDR Blog V3 => Working

And now it gets interesting:

PC - new 3m USB extension - 1m mini USB cable - passive USB Hub - 80cm uUSB cable - Kerberossdr => Working
PC - old 3m USB extension - 1m mini USB cable - passive USB Hub - 80cm uUSB cable - Kerberossdr => Working

PC - new 3m USB ext. - old 3m USB ext. - 1m mini USB cable - passive USB Hub - 80cm uUSB cable - Kerberossdr => Working!
PC - old 3m USB ext. - 1m mini USB cable - passive USB Hub - new 3m USB ext. - 80cm uUSB cable - Kerberossdr => Not Working!
PC - new 3m USB ext. - 1m mini USB cable - passive USB Hub - old 3m USB ext. - 80cm uUSB cable - Kerberossdr => Not Working!

So it is possible to setup a connection over 7.8 meters with a passive USB hub in between. But the unrefreshed USB signal from Kerberossdr seems not to survive more than a meter. :roll:

Username
Posts: 462
Joined: Sun Oct 09, 2016 7:27 am

Re: Strange USB problems

Post by Username » Thu Jul 18, 2019 11:21 am

Hi
My HackRF work with an short USB Cable to. With the longer not. Strange.
I got from China a USB to Fiber Adapter with that the problem should solved. :D

Post Reply