Newest Version SDR

Need help installing or figuring out something about your SDR? Ask here.
Post Reply
Posts: 2
Joined: Fri Mar 12, 2021 6:59 pm

Newest Version SDR

Post by Montana_SDR » Fri Mar 12, 2021 7:10 pm

Yesterday I ran into problems with my copy of SDR#. I think it was 1704. I downloaded it in early February. It always took a long time to load and often gave the error message "SDR# not responding". But it worked. Until yesterday when a new update for Windows 10 was installed. Then my familiar side displays were gone and I could not receive any AM (MW) stations.
So I erased my old copy and downloaded the latest version. I also downloaded .net 5 for 486 machines.
I used the Community copy from Chile that has all the plugins. It downloaded fine and the wizard walked me through the installation.
I checked the install file and it confirmed that everything installed fine.
But when I start SDR# the white Airspy logo appears for about 20 seconds. Then it disappears and nothing happens. The program does not seem to want to load.
Any suggestions are appreciated. I love the program and use it with an Airspy Discovery +.
Thanks in advance.

Posts: 180
Joined: Fri Jun 30, 2017 11:34 am

Re: Newest Version SDR

Post by tim_rtd » Fri Mar 12, 2021 9:41 pm

Try the event viewer ,right click on that windows in the bottom left corner of win 10.
open windows logs.
Start your SDR# app and let it crap out.
click the Applications selector and at the top you'll see the error log. Read it.....
I have similar issue, My system does not like the new PortAudio.dll file. I just drop in an old port audio .dll and all's fine. Other people have different issues, perhaps due to what version of .net... I hear you have to install the 32 bit version.

Posts: 2
Joined: Fri Mar 12, 2021 6:59 pm

Re: Newest Version SDR

Post by Montana_SDR » Fri Mar 12, 2021 11:41 pm

I found the Windows Event Viewer app by typing Event Viewer into the Search box on the left side of the task bar.
Then I studied the Viewer screen and followed your instructions.
Then I ran my newest copy of SDR#. It crapped out just like before.
When I checked the Event Viewer Applications log, the error file jumped out. I clicked on it and here is the error message it provided:

Faulting application name: SDRSharp.exe, version:, time stamp: 0x600b9e79
Faulting module name: portaudio.DLL, version:, time stamp: 0x00000000
Exception code: 0x40000015
Fault offset: 0x0002df28

Just like you said! I took a portaudio.dll file from my SDR# 1704 version and copied it over the newer file. Then I restarted the newest version of SDR# and it ran fine! For folks who do not have a 1704 version they can download it from the Airspy SDR download page.

The 32 bit or (486) version of .NET must be used. I mistakenly downloaded the 64 bit version and SDR would not recognize it.

Thanks for the excellent tip! Made my day. Now I can listen to the radio tonight. Looks like there is a new version of the Broadband recorder included with the Community download. There are a lot of other plugins included too. Thanks to our friends in Chile!
I am anxious to try them out tonight.

Post Reply