Can you help me with this? Stick doesn't detect / work

Main forum to discuss RTL-SDR related topics.
Post Reply
Doctor_Felix
Posts: 2
Joined: Fri Aug 05, 2016 12:13 pm

Can you help me with this? Stick doesn't detect / work

Post by Doctor_Felix » Fri Aug 05, 2016 12:22 pm

I bought a DVBT Stick with the 820T2 chip and SDR Capability. It looks like this:
http://g02.a.alicdn.com/kf/HTB16qx1KVXX ... Dongle.jpg

I didn't get it to work under windows so i tried linux...
The rtl_test -t command says:

Code: Select all

Found 1 device(s):
  0:  , , SN:

Using device 0: Generic RTL2832U OEM
rtlsdr_write_reg failed with -1
Resetting device...
rtlsdr_write_reg failed with -4
rtlsdr_write_reg failed with -4
rtlsdr_write_reg failed with -4
rtlsdr_write_reg failed with -4
rtlsdr_write_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_read_reg failed with -4
rtlsdr_write_reg failed with -4
rtlsdr_read_reg failed with -4
rtlsdr_write_reg failed with -4
rtlsdr_read_reg failed with -4
rtlsdr_write_reg failed with -4
rtlsdr_read_reg failed with -4
rtlsdr_write_reg failed with -4
No supported tuner found
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
Enabled direct sampling mode, input 1
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
Supported gain values (1): 0.0
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
WARNING: Failed to set sample rate.
No E4000 tuner found, aborting.
rtlsdr_write_reg failed with -4
When you run rtl_test -t a second time it says:
No supported devices found.

Its the same on a PC and on the raspberry pi
I hope one of you can help me.
Thx the doctor

Doctor_Felix
Posts: 2
Joined: Fri Aug 05, 2016 12:13 pm

Re: Can you help me with this? Stick doesn't detect / work

Post by Doctor_Felix » Thu Aug 25, 2016 9:38 am

can no one help me with this?

rtlsdrblog
Site Admin
Posts: 1874
Joined: Mon Nov 19, 2012 11:54 pm

Re: Can you help me with this? Stick doesn't detect / work

Post by rtlsdrblog » Thu Aug 25, 2016 10:21 am

What happens when you try to run it under Windows?

On Linux it looks like maybe you haven't blacklisted the DVB-T drivers, or the rules file didn't copy over correctly.

Either that or its simply faulty.

Kenn
Posts: 45
Joined: Fri Apr 08, 2016 8:43 pm

Re: Can you help me with this? Stick doesn't detect / work

Post by Kenn » Thu Aug 25, 2016 11:20 pm

This is the procedure I use to get RTL dongles working in Linux Mint. If I had a dongle that didn't work after this I'd try it on a different machine with a confirmed good USB port just to be sure. If it still didn't work, I'd be inclined to think the dongle itself is defective.


Installing the drivers:

1. Open a terminal and confirm you're in your home directory. This is the preferred convention and will be assumed throughout this text.

2. Update your distribution.
sudo apt-get update

3. Install the tools needed to retrieve (git), compile (cmake) and build (build-essential).
sudo apt-get install git
sudo apt-get install cmake
sudo apt-get install build-essential

4. Install libusb-1.0-0-dev which is a C library that provides generic access to USB devices.
sudo apt-get install libusb-1.0-0-dev

5. Retrieve, build and compile the RTL2832U Osmocom drivers from the source.
git clone git://git.osmocom.org/rtl-sdr.git
cd rtl-sdr/
mkdir build
cd build
cmake ../ -DINSTALL_UDEV_RULES=ON
make
sudo make install
sudo ldconfig
sudo cp ../rtl-sdr.rules /etc/udev/rules.d/

6. Blacklist the default driver that is automatically loaded for using the dongle as a TV device as it doesn't work for SDR purposes and clashes with the new Osmocom drivers we just installed.
A. Open your /etc/modprobe.d folder as an administrator.
B. Create a new file 'blacklist-rtl.conf' and add this one line:blacklist dvb_usb_rtl28xxu
C. Save the file, close the editor and restart the machine.

7. Test that the dongle is working:
rtl_test -t

You should see something remarkably like:
Found 1 device(s):
0: Realtek, RTL2838UHIDIR, SN: 00000001
Using device 0: Generic RTL2832U OEM
Found Rafael Micro R820T tuner

And a few others lines. Don't worry about messages like PLL not locked or E4000
tuner not found or that it says R820T and not R820T2. If you're seeing this then
you're drivers are working. You're now ready to install some applications.

stuartr
Posts: 2
Joined: Sat Jun 24, 2017 10:45 pm

Re: Can you help me with this? Stick doesn't detect / work

Post by stuartr » Sat Jun 24, 2017 10:49 pm

Having a similar problem. I've followed the instructions to the letter down the step 7, and now I'm seeing:

~ $ rtl_test -t
Found 1 device(s):
0: Realtek, RTL2838UHIDIR, SN: 00000001

Using device 0: Generic RTL2832U OEM
No supported tuner found
Enabled direct sampling mode, input 1
Supported gain values (1): 0.0
Sampling at 2048000 S/s.
No E4000 tuner found, aborting.

An earlier post suggests perhaps "the rules didn't copy over correctly" but which step is it I need to repeat to fix this?

rtlsdrblog
Site Admin
Posts: 1874
Joined: Mon Nov 19, 2012 11:54 pm

Re: Can you help me with this? Stick doesn't detect / work

Post by rtlsdrblog » Mon Jun 26, 2017 2:40 am

stuartr wrote:Having a similar problem. I've followed the instructions to the letter down the step 7, and now I'm seeing:

~ $ rtl_test -t
Found 1 device(s):
0: Realtek, RTL2838UHIDIR, SN: 00000001

Using device 0: Generic RTL2832U OEM
No supported tuner found
Enabled direct sampling mode, input 1
Supported gain values (1): 0.0
Sampling at 2048000 S/s.
No E4000 tuner found, aborting.

An earlier post suggests perhaps "the rules didn't copy over correctly" but which step is it I need to repeat to fix this?
What happens if you don't use the -t flag? I believe the -t flag is only supported by E4000 units.

Copying the rules: From the build folder use the following

sudo cp ../rtl-sdr.rules /etc/udev/rules.d/

stuartr
Posts: 2
Joined: Sat Jun 24, 2017 10:45 pm

Re: Can you help me with this? Stick doesn't detect / work

Post by stuartr » Thu Jun 29, 2017 5:48 pm

Looks like the problem was that the stick was in direct sampling mode - no idea how it got there! (Or how to get it out.) But in any case it turned out that it wasn't a tuner of the preferred 820T2 breed. I bought another one that was, and it worked instantly!

rtlsdrblog
Site Admin
Posts: 1874
Joined: Mon Nov 19, 2012 11:54 pm

Re: Can you help me with this? Stick doesn't detect / work

Post by rtlsdrblog » Fri Jun 30, 2017 5:28 am

stuartr wrote:Looks like the problem was that the stick was in direct sampling mode - no idea how it got there! (Or how to get it out.) But in any case it turned out that it wasn't a tuner of the preferred 820T2 breed. I bought another one that was, and it worked instantly!
Hmm direct sampling mode is activated by specifying a specific flag, which I don't think you did?

Most of the other tuners are not really supported that well these days, only the R820T/2 survives.

nisha
Posts: 2
Joined: Fri Dec 08, 2017 6:32 pm

Re: Can you help me with this? Stick doesn't detect / work

Post by nisha » Fri Dec 08, 2017 6:34 pm

I got the same error. Did someone get any solution?

tim_rtd
Posts: 60
Joined: Fri Jun 30, 2017 11:34 am

Re: Can you help me with this? Stick doesn't detect / work

Post by tim_rtd » Tue Dec 12, 2017 2:46 pm

I use to see this ..output
rtlsdr_write_reg failed with -4
rtlsdr_write_reg failed with -4
rtlsdr_write_reg failed with -4
rtlsdr_write_reg failed with -4

When I have low voltage getting to the dongle thru the usb port. Try an active usb hub to plug in the dongle.

Post Reply