Radio Frequency interference at Raspberry Pi's

Need help installing or figuring out something about your SDR? Ask here.
Post Reply
sjonkeesse
Posts: 7
Joined: Wed Nov 22, 2017 10:42 pm

Radio Frequency interference at Raspberry Pi's

Post by sjonkeesse » Thu Nov 23, 2017 12:15 am

Hi there, for a couple months now I am experiencing with the RTL2832 dongle. I am trying to see if there are signals in the air. For example to see if someone is using a remote, and how far away this signal could be.
First I started sampling with my MacBook Pro and had good and clear results.

You can see sharp constant channels
Macbook Pro, 5mhz bandwidth, 2 frequency hops. (image cropped)
Image

However I want to make this more portable, for example with an Raspberry Pi (3 B).
When I am trying to achieve the above with the same settings I see a lot of 'static?'. The frequency range in this image is slightly different, but the result is overal the same.
Raspberry Pi 3B, 2mhz bandwidth, no frequency hops.
Image

And when I use frequency hopping to get a range of 5mhz the result gets a lot worse. This image is cropped. The soft yellow bars in this waterfall are indicating there is activity, but there isn't. This I have tested with another dongle at te same time on my Macbook.
Raspberry Pi 3B, 5mhz bandwidth, 2 frequency hops. (image cropped)
Image

Then I tried to use Raspberry Pi Zero with worse results.
Raspberry Pi Zero, 5mhz bandwidth, 2 frequency hops. (image cropped)
Image

Also with just 1 mhz bandwidth
Raspberry Pi Zero, 1mhz bandwidth, no frequency hops.
Image

Raspberry Pi Zero, 2.8mhz bandwidth, no frequency hops.
Image

In my experience: the less the bandwidth, the better the result.

I have tried the following things to see if it had an influence on the static:
  • Different antennas
  • Different antenna cables and connectors
  • Different rtl-sdr repositories
  • Different power supplies (wall adapter, powerbank)
  • Different power cables (short usb cable, isolated cables, directly soldered)
  • Different usb connections (onboard usb, with extension cable, soldered directly (raspberry pi zero))
  • Different RTL2832 dongles
  • Different environments
  • Disabled wifi and bluetooth
  • Tried with overclocking raspberry pi's
All of this with no better results.

I can get a more worse output when I use an usb hub between my raspberry and dongle (also if nothing else is connected). Or when I increase the bandwidth of the dongle.

Does anyone have any suggestion about how to reduce this static or weird signal reflections in my output? Or does anybody know where this is coming from?

Thanks in advance!
Last edited by sjonkeesse on Sun Dec 10, 2017 1:57 pm, edited 3 times in total.

rtlsdrblog
Site Admin
Posts: 1349
Joined: Mon Nov 19, 2012 11:54 pm

Re: Signal reflection or static at Raspberry pi's

Post by rtlsdrblog » Thu Nov 23, 2017 1:57 am

Were you using the same antennas on the Pi and with your Macbook?

Possibly the signal strength on your raspberry pi was a lot higher due to being in a better location. If the signal strength from strong stations like broadcast FM is very high then the dongle can overload, and cause images across the spectrum.

To solve it either turn down the gain, use attenuation, or use a filter to block out the strong unwanted signals.

sjonkeesse
Posts: 7
Joined: Wed Nov 22, 2017 10:42 pm

Re: Signal reflection or static at Raspberry pi's

Post by sjonkeesse » Thu Nov 23, 2017 12:02 pm

@rtlsdrblog thank you for your response.

I use exactly the same hardware except for the Raspberry Pi('s) as computer in stead of the Macbook.
Also I tested this at exactly the same time at the same location.

To reduce te noise in the waterfall it is possible to turn the gain down or on auto. But than it will also show less activity and less strong activity in the waterfall.

Macbook with gain 50 (maximum)
Image

Raspberry Pi zero with gain auto
Image

You can clearly see more detail from further away with my Macbook. So setting the gain to auto, which will result in lower gain, is no option...

Also for this setup I used the same devices RTL2832 820T2 with the same antennas etc. (also tried to switch them, even know it is the same hardware type)

rtlsdrblog
Site Admin
Posts: 1349
Joined: Mon Nov 19, 2012 11:54 pm

Re: Static or noise at Raspberry Pi's

Post by rtlsdrblog » Fri Nov 24, 2017 2:52 am

It does look like the Pi is somehow causing interference peaks, which might be overloading the dongle. You could try a few things. First confirm if the Pi is producing noise by looking at those frequencies in GQRX on your Mac and turning the Pi on and off.

If it is the Pi you could try a metal shielding box for the Pi, or perhaps a different power supply (maybe a even linear power supply).

sjonkeesse
Posts: 7
Joined: Wed Nov 22, 2017 10:42 pm

Re: Static or noise at Raspberry Pi's

Post by sjonkeesse » Thu Dec 07, 2017 8:22 pm

I've tried it all, i've used three different pi's (1x zero, 2x model 3). Because of the differences in result between models, I thought maybe I can trie some other boards. So I just tried an Asus Tinker Board. This board has a dedicated chip for the usb connection, where the raspberry pi's has a shared chip for usb and ethernet.

This time I tested three devices at the same time at the same place; macbook, pi model 3b, asus tinker board.

All devices runned a version of keenerd's rtl-sdr library. I ran this command for each device:

Code: Select all

rtl_power -f 383M:385M:1k -i 1 -g 50 -P output.csv
With these results:
Image

... so there are additional signals visible with the pi and thinker board, at different frequencies.

The naked sdr sticks are the same as the one with the case.
Image

Even known at this picture they are all standing next to each other, I also tested this with greater distance.


If I zoom in at this spooky activity, for example at the Thinker board 383.68 Mhz, the activity becomes less and less.
0.4 Mhz bandwidth

Code: Select all

rtl_power -f 383.35M:383.75M:1k -i 1 -g 50 -P output.csv
Image

0.25 Mhz bandwidth

Code: Select all

rtl_power -f 383.5M:383.75M:1k -i 1 -g 50 -P output.csv
Image

0.1 Mhz bandwidth

Code: Select all

rtl_power -f 383.65M:383.75M:1k -i 1 -g 50 -P output.csv
Image

sjonkeesse
Posts: 7
Joined: Wed Nov 22, 2017 10:42 pm

Re: Static or noise at Raspberry Pi's

Post by sjonkeesse » Thu Dec 07, 2017 11:09 pm

Now i've tried something else which has influence on these signals. I used an good usb extension cable which gave more static but little lesser static. If I hold the usb metal in my hand, at the dongle side, the static reduces a lot and the real signals become a lot more clear. The 'spooky' signals are still present, but way less.

Image

This post says there is some sort of design flaw with the sdr dongle. To reduce RFI they advise to not connect the usb shield. Maybe this has something to do with it.
https://www.rtl-sdr.com/tip-reduce-radi ... e-rtl-sdr/
http://sinnet3000.blogspot.nl/2013/03/r ... l-sdr.html
http://www.radioforeveryone.com/p/reduc ... noise.html

sjonkeesse
Posts: 7
Joined: Wed Nov 22, 2017 10:42 pm

Re: Radio Frequency interference at Raspberry Pi's

Post by sjonkeesse » Sun Dec 10, 2017 2:06 pm

Today I tried an other SDR dongle at my macbook. This dongle is even worse!

'Newgen. RTL2832SDR'
https://www.ebay.com/itm/RTL-SDR-USB-Do ... 2749.l2649
Image
Image

'DVB-T+FM+DAB 820T2 & SDR' (RTL2832 also)
https://www.ebay.com/itm/USB-2-0-Digita ... 1eafeea510
Image
Image

The interference (yellow shizzle) is visible on the whole spectrum.

Tomorrow I will try it again with an NooElec NESDR SMArt.

sjonkeesse
Posts: 7
Joined: Wed Nov 22, 2017 10:42 pm

Re: Radio Frequency interference at Raspberry Pi's

Post by sjonkeesse » Mon Dec 11, 2017 3:11 pm

Today I received my NESDR SMArt dongle. The result in GQRX on my MacBook is not that different from my other dongle type. Also the interference is still visible with the Tinker Board but less. I did not try to improve this in any way so far with this dongle.

Image

Code: Select all

rtl_power -f 383M:385M:1k -i 1 -g 50 -P output.csv
NESCR SMArt dongle & Tinker board:
Image

Blue RTL2832U R820T2 dongle & Tinker board:
Image

Using NESCR SMArt & Macbook:
Image

rtlsdrblog
Site Admin
Posts: 1349
Joined: Mon Nov 19, 2012 11:54 pm

Re: Radio Frequency interference at Raspberry Pi's

Post by rtlsdrblog » Tue Dec 12, 2017 10:01 am

Must be noise generated by the Rpi then. Try another SBC or work on shielding the Pi.

You can try and remove the shield from the USB cable. It's not really a design flaw, that post is quite old and not 100% correct. But removing the shield connection can help in some cases.

bobasaurus
Posts: 16
Joined: Wed Dec 27, 2017 4:36 am
Location: Colorado

Re: Radio Frequency interference at Raspberry Pi's

Post by bobasaurus » Wed Dec 27, 2017 5:08 am

The power supply suggestion was a good one, maybe pick up a quality 2.5A+ 5V filtered DC supply and power the Pi off it.

Post Reply