Failure to build poppler on Mac

Main forum to discuss RTL-SDR related topics.
Post Reply
skecher
Posts: 2
Joined: Thu Dec 21, 2017 7:09 pm

Failure to build poppler on Mac

Post by skecher » Thu Dec 21, 2017 7:12 pm

Hi there, I found the link to build on Mac, Yosemite specifically.

However when it starts to build, the log shows the following error:

:info:build distutils.errors.DistutilsPlatformError: $MACOSX_DEPLOYMENT_TARGET mismatch: now "10.7" but "10.10" during configure

Where do I set the correct environment variable?

Thank you, Caesar.

rtlsdrblog
Site Admin
Posts: 2563
Joined: Mon Nov 19, 2012 11:54 pm

Re: Failure to build poppler on Mac

Post by rtlsdrblog » Fri Dec 22, 2017 1:14 pm

What software is this about?

skecher
Posts: 2
Joined: Thu Dec 21, 2017 7:09 pm

Re: Failure to build poppler on Mac

Post by skecher » Wed Dec 27, 2017 11:51 pm

Hi this is about gqrx which is linked via here https://www.rtl-sdr.com/rtl-sdr-quick-start-guide/

Thanks, Caesar.

This is the command line output:

Code: Select all

$ sudo port install gqrx
--->  Computing dependencies for gqrx
The following dependencies will be installed: 
 SDRplay
 SoapySDR
 airspy
 bladeRF
 coreutils
 docbook-xml
 docbook-xml-4.1.2
 docbook-xml-4.2
 docbook-xml-4.3
 docbook-xml-4.4
 docbook-xml-5.0
 docbook-xsl
 findutils
 getopt
 gnuradio
 gpsd
 gr-fcdproplus
 gr-osmosdr
 gzip
 hackrf
 orc
 pcre2
 poppler
 potrace
 qt5-qtbase
 qt5-qtsvg
 tecla
 texlive-basic
 texlive-bin
 texlive-common
 texlive-latex
 uhd
 volk
 xmlto
 xorg-libXp
 xorg-printproto
Continue? [Y/n]: 
--->  Building poppler
Error: Failed to build poppler: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_poppler/poppler/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port gqrx failed
I've attached the log referenced above.

The salient part is at the bottom below ($MACOSX_DEPLOYMENT_TARGET mismatch: now "10.7" but "10.10" during configure):

Code: Select all

:info:build   File "/opt/local/bin/g-ir-scanner", line 66, in <module>
:info:build     sys.exit(scanner_main(sys.argv))
:info:build   File "/opt/local/lib/gobject-introspection/giscanner/scannermain.py", line 538, in scanner_main
:info:build     ss = create_source_scanner(options, args)
:info:build   File "/opt/local/lib/gobject-introspection/giscanner/scannermain.py", line 446, in create_source_scanner
:info:build     ss.parse_files(filenames)
:info:build   File "/opt/local/lib/gobject-introspection/giscanner/sourcescanner.py", line 262, in parse_files
:info:build     self._parse(headers)
:info:build   File "/opt/local/lib/gobject-introspection/giscanner/sourcescanner.py", line 307, in _parse
:info:build     self._cpp_options)
:info:build   File "/opt/local/lib/gobject-introspection/giscanner/ccompiler.py", line 210, in preprocess
:info:build     extra_postargs=extra_postargs)
:info:build   File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/distutils/unixccompiler.py", line 111, in preprocess
:info:build     self.spawn(pp_args)
:info:build   File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/distutils/ccompiler.py", line 876, in spawn
:info:build     spawn(cmd, dry_run=self.dry_run)
:info:build   File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/distutils/spawn.py", line 38, in spawn
:info:build     _spawn_posix(cmd, search_path, dry_run=dry_run)
:info:build   File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/distutils/spawn.py", line 139, in _spawn_posix
:info:build     raise DistutilsPlatformError(my_msg)
:info:build distutils.errors.DistutilsPlatformError: $MACOSX_DEPLOYMENT_TARGET mismatch: now "10.7" but "10.10" during configure
:info:build make[4]: *** [Poppler-0.18.gir] Error 1
:info:build make[4]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports

rtlsdrblog
Site Admin
Posts: 2563
Joined: Mon Nov 19, 2012 11:54 pm

Re: Failure to build poppler on Mac

Post by rtlsdrblog » Thu Dec 28, 2017 1:11 am

I'm not too sure on the cause of those errors, perhaps 10.10 is simply not supported very well anymore. I see that there is a ready to go binary for 10.11 on gqrx.dk/download/. Can you upgrade and use that version? Might be easier than trying to solve all the broken old dependencies.

Either that or you could try CubicSDR which also runs on OSX.

Post Reply