New user install, no Bulk-In, Interface (Interface 0)

Need help installing or figuring out something about your SDR? Ask here.
Post Reply
martinmarty
Posts: 2
Joined: Tue Jun 19, 2018 6:10 pm

New user install, no Bulk-In, Interface (Interface 0)

Post by martinmarty » Tue Jun 19, 2018 6:58 pm

Hello,

Yesterday I received my RTL-SDR Blog R820T2 RTL2832U purchased from Amazon:
https://www.amazon.com/gp/product/B011H ... UTF8&psc=1

I am having problems with the installation. It does not seem to be showing up in the zadig program. I have turned on the option to List All Devices and turned off Ignore Hubs or Composite Parents.

I have tried this on three machines all running Win 10 64-bit, I think two at 1709 and one at 1803. I have attached a screen shot from the PC with the least complicated USB environment.

I have tried a variety of USB ports, 2.0, 3.0, on motherboard, front-panel and expansion card.
When I plug in the SDR dongle Windows makes a USB connection sound and gives an error that the device install failed. This seems normal except that it doesn't show up in zadig. I am running zadig as admin.

The bat file part of the install seemed to go OK and you can see by the screen shot the two files are in place.

All help appreciated.

Thanks,
-Marty
Attachments
RTL-SDR screen.jpg
RTL-SDR screen.jpg (396.12 KiB) Viewed 400 times

rtlsdrblog
Site Admin
Posts: 1788
Joined: Mon Nov 19, 2012 11:54 pm

Re: New user install, no Bulk-In, Interface (Interface 0)

Post by rtlsdrblog » Wed Jun 20, 2018 3:58 am

Does the device show up in device manager as anything?

The fact that it's showing Unknown USB Device and the wrong USB ID makes me think that the RTL2832U chip on the dongle might be faulty.

Can you email me with your order ID number at [email protected]? I'll try send you a replacement.

martinmarty
Posts: 2
Joined: Tue Jun 19, 2018 6:10 pm

Re: New user install, no Bulk-In, Interface (Interface 0)

Post by martinmarty » Wed Jun 20, 2018 4:09 pm

Done. THANK YOU VERY MUCH! -Marty

Post Reply