SDR shows up with two bulk-in interfaces

Need help installing or figuring out something about your SDR? Ask here.
Post Reply
Posts: 1
Joined: Sun Jul 08, 2018 9:29 pm

SDR shows up with two bulk-in interfaces

Post by traceur » Sun Jul 08, 2018 9:49 pm

I have two SDR's (A NESDR Smart, and a RTL-SDR v3) which were working fine three days ago. Last night my computer decided to do a windows update, which wiped out the drivers. No surprise there. But when I plug in either of the SDR's they show up as two bulk-in interfaces each (both in Device Manager and in zadig).
DManager.jpg (99.51 KiB) Viewed 21088 times
Then when both are plugged in it shows up as four, Bulk-in (0) to Bulk-in (3).
SDRcontr.jpg (38.81 KiB) Viewed 21088 times
I can still get them to work in SDR# by using the two that work. (The other two fail to start.) But Unitrunker has trouble figuring it out and can only get one of the SDR's running. So, I'm looking for help. Is there a reason for it showing up as two bulk-in interfaces? Can I fix it and recombine them back into one? I have already tried updating the drivers, removing/uninstalling the devices and reinstalling the drivers, restarting the programs, and my computer multiple times, and even reinstalling the USB drivers. I'm at a loss of what to do next.

Site Admin
Posts: 2877
Joined: Mon Nov 19, 2012 11:54 pm

Re: SDR shows up with two bulk-in interfaces

Post by rtlsdrblog » Wed Jul 11, 2018 12:15 am

Weird, no idea why or how Windows would show it that many times.

I'd try uninstalling all the drivers, and then installing again.

Posts: 1
Joined: Wed Nov 21, 2018 5:27 pm

Re: SDR shows up with two bulk-in interfaces

Post by WhirlPool » Wed Nov 21, 2018 5:35 pm

I'm having this problem too.


Tried uninstalling and removing the drivers.
Reinstalled using Zadig 2.4 and the result is the same.

It's not a big issue as the devices work.
It's just annoying ...

Posts: 1
Joined: Wed Dec 19, 2018 12:08 pm

Re: SDR shows up with two bulk-in interfaces

Post by pashpe » Wed Dec 19, 2018 12:15 pm

OK, I have the same issue with lost audio. Installed on a Win10 machine, worked without issue. Then I plugged the RTL-SDR into a different USB port, and now AirSpy shows two Bulk-In interfaces, 0 and 1 whereas the prior successful operation only showed interface 0. So, I verified driver, and tried using interface 1. It appears to work as I selected known FM broadcast station and there is activity displayed but now no audio. So I uninstalled all that I could find and started again, and AirSpy still shows two devices, and interface 0 no longer installed. So where in the computer is the hidden driver or configuration file that is causing this issue? Anyone know? Moving to a different USB port is my best analysis as to the start of my woes. Thanks in advance for a solution.

Posts: 3
Joined: Sat Jan 26, 2019 8:56 am

Re: SDR shows up with two bulk-in interfaces

Post by beast6228 » Thu Jan 31, 2019 8:50 am

Usually you will get several devices if you switch usb ports. The only way to fix it is by uninstalling the drivers, clean your system of ghost drivers by using Device Cleanup and then reinstall the drivers.

User avatar
Posts: 26
Joined: Wed Jan 30, 2019 7:27 pm

Re: SDR shows up with two bulk-in interfaces

Post by Corrosive » Fri Feb 01, 2019 7:34 pm

I wish I had a solution for that... The tablet in my car is Windows 10 and I have 3 SDRs attached to it.
For some reason after an update I one of them showing up with double the interfaces. This only happens with one of the three which is even more strange.

Posts: 1
Joined: Thu Sep 24, 2020 3:56 am

Re: SDR shows up with two bulk-in interfaces

Post by quartapound » Thu Sep 24, 2020 4:07 am

I have found the solution to this problem!

I also was having dongles appear as more than one device.

it's because the serial numbers are named 00000001, 00000002, etc

do NOT use 00000000, 00000001, 00000002, 0, 1, 2 etc, as these numbers will cause conflict with device index which are 0, 1, 2, etc.

Rename the Serial numbers as 101, 102, 103, etc.

As soon as you do this, the device will appear as 1 device inside SDR# and other programs.

I was not able to use RTL1090 to rename the serial numbers, because it fails on the corrupt device '0'
unplug all dongles but one of them
try rtl_test and you'll see it shows up as "2" devices and fails
use rtl_eeprom -s 00000101

(where S represents the serial number. remember, don't use a single digit, it screws things up)

this will probably still fail, because rtl_eeprom is trying to write to device 0

use rtl_eeprom -d 1 -s 0000101

(this allows it to overwrite the 'second' device')

unplug dongle, plug back in

check with rtl_test again..... now it's only 1 dongle :)

This was driving me nuts.

Now it shows up properly in SDR# without 'ghost' devices and duplicates

Posts: 1
Joined: Thu Feb 25, 2021 8:41 pm

Re: SDR shows up with two bulk-in interfaces

Post by Maxtor » Thu Feb 25, 2021 8:59 pm

Hi.. I'm new to community and I also have a Nooelec. It's been a while since last post but I probably found a super simple solution to this issue.

Found this discussion here cause I had the same problem but what I found at last - It is probably caused only by missing correct RL driver before the nooelec installation!! Nothing extra nad special. Windows will install just "some" wrong driver by itself when you will plug it in for the first time.

What it did:
(..according to online guide that is wrong in case of Win10)
(my setup: NESDR SMArTee v2 SDR / Windows 10 with latest updates)

01 - Insert device into USB port (2 devices are installed after that automatically)
02 - Open nooelec installer (and this is probably wrong!! - you should continue with step 04!!)
03 - Install driver as it is in online guide (I did it for both devices and there are still two of these but it works fine)
04 - Open Windows Update and check for updates
05 - There will be an offer to install not forced updates (there are only drivers for your devices usually)
06 - That's it !!! There will be RL driver ready to be installed if you will open it - Do it
07 - From now on you have only one device installed and you can go back to the second step and install nooelec driver correctly

Post Reply