Using Direwolf iGate on Raspberry pi incorrect Freq

Need help installing or figuring out something about your SDR? Ask here.
Post Reply
kg4aao
Posts: 1
Joined: Mon Aug 13, 2018 10:18 pm

Using Direwolf iGate on Raspberry pi incorrect Freq

Post by kg4aao » Mon Aug 13, 2018 10:27 pm

Good day all. I have used my rtl_sdr for some time. Never really had issues I could't deal with, until now....

I have set up an APRS iGate on a raspberry pi 3. I followed this guide (Mentioned here on rtl-sdr.com) http://qso365.co.uk/2018/04/updated-gui ... ilt-image/

No errors, setup when fine however, when I enter the test command the frequency is off.

Reading config file sdr.conf
Audio input device for receive: stdin (channel 0)
Audio out device for transmit: null (channel 0)
Channel 0: 1200 baud, AFSK 1200 & 2200 Hz, E+, 24000 sample rate.
Note: PTT not configured for channel 0. (Ignore this if using VOX.)
Ready to accept AGW client application 0 on port 8000 ...
Use -p command line option to enable KISS pseudo terminal.
Ready to accept KISS client application on port 8001 ...
Found 1 device(s):
0: Realtek, RTL2838UHIDIR, SN: 00000001

Using device 0: Generic RTL2832U OEM
Detached kernel driver
Found Rafael Micro R820T tuner
Tuner gain set to 49.60 dB.
Tuned to 144642000 Hz. <<<---- Should be 144.390 Hz.
Oversampling input by: 42x.
Oversampling output by: 1x.
Buffer size: 8.13ms
Exact sample rate is: 1008000.009613 Hz
Sampling at 1008000 S/s.
Output at 24000 Hz.
Connect to IGate server noam.aprs2.net (2607:7c80:54:a::4410) failed.

The test command line : sudo rtl_fm -f 144.39M -g 49.2 - | direwolf -c sdr.conf -r 24000 -D 1 -

Any idea as to what I have done wrong?

rtlsdrblog
Site Admin
Posts: 1858
Joined: Mon Nov 19, 2012 11:54 pm

Re: Using Direwolf iGate on Raspberry pi incorrect Freq

Post by rtlsdrblog » Tue Aug 14, 2018 2:04 am

Is the frequency actually off and you're getting no decodes?

The RTL-SDR software will sometimes tune to a slightly offset LO, but tune the IF to the specified frequency.

Post Reply