RTL-SDR v3 direct sampling over a network

Need help installing or figuring out something about your SDR? Ask here.
Post Reply
ljones
Posts: 4
Joined: Fri Oct 12, 2018 8:19 pm

RTL-SDR v3 direct sampling over a network

Post by ljones » Fri Oct 12, 2018 8:49 pm

Hello all!

First of all a quick summing up of the problem: I cannot get my RTL-SDR v3 stick to use direct sampling over a wireless network. Tuning low (HF) frequencies dosen't work at all (but does work if I do it directly via USB rather than a wifi network).

Here are the devices I'm using:

The first device is a raspberry pi 3 running raspbian. I'm using rtl-sdr to obtain rtl_tcp ( found at https://www.rtl-sdr.com/rtl-sdr-blog-v- ... ser-guide/ ) - I'm using the instructions found under the section "Modified rtl_tcp for direct sampling". This compiled fine on the raspberry pine and I'm able to run it without errors at a command, such as:

Code: Select all

$ rtl_tcp -a 192.168.0.139 -D 2 -s 240000
The second machine is a normal x86 machine running debian stretch and GQRX version 2.11.5 . I can tune and listen for FM radio fine but if I try to use HF, I get nothing but static, no signal.

I have GQRX set up with these settings:

- Device=other
- Input rate = 240000
- Device string = rtl_tcp=192.168.0.139:1234

I'm aware that to use direct sampling in GQRX I need to add "rtl=0,direct_samp=2" (without the quotes) to the device string section. However that appears to be only for use with a direct USB device, not network/tcp. If I try to do that as soon as I try to use GQRX I get this error:

Code: Select all

Generating taps for new filter   LO:-5000   HI:5000 TW:2000   Taps: 115
terminate called after throwing an instance of 'std::runtime_error'
  what():  throttle(53): insufficient connected output ports (1 needed, 0 connected)
Aborted
I'm guessing that rtl=0,direct_samp=2 is only for using USB devices direct (also leaving off rtl=0 does the same thing). But is there some sort of setting I need to use with either rtl_tcp or gqrx to be able to use HF and direct sampling at all ? So far I've drawn a blank I can find plenty of people using gqrx with direct sampling or using rtl_tcp with direct sampling but *not* using them both together!

I should add that if I use the RTL-SDR v3 stick directly on a PC with debian stretch and gqrx I don't have these problems; FM *and* HF work fine with direct sampling. I also have GQRXs' "No limits" enabled in all cases.

Output of code from raspberry pi after running rtl_tcp:

Code: Select all

Found 1 device(s):
  0:  Realtek, RTL2838UHIDIR, SN: 00000001

Using device 0: Generic RTL2832U OEM
Found Rafael Micro R820T tuner
[R82XX] PLL not locked!
Enabled direct sampling mode, input 2
Tuned to 100000000 Hz.
Bandwidth set to automatic resulted in 350000 Hz.
listening...
Use the device argument 'rtl_tcp=192.168.0.139:1234' in OsmoSDR (gr-osmosdr) source
to receive samples in GRC and control rtl_tcp parameters (frequency, gain, ...).
Thankies

ljones

rtlsdrblog
Site Admin
Posts: 1878
Joined: Mon Nov 19, 2012 11:54 pm

Re: RTL-SDR v3 direct sampling over a network

Post by rtlsdrblog » Sat Oct 13, 2018 8:43 am

When you say it doesn't work, do you mean that GQRX doesn't connect, or that you're just not getting reception?

I believe in GQRX you need to set "no-limits tuning" to be able to tune to the lower frequencies. Can you check if you've ticked that box?

ljones
Posts: 4
Joined: Fri Oct 12, 2018 8:19 pm

Re: RTL-SDR v3 direct sampling over a network

Post by ljones » Sat Oct 13, 2018 12:03 pm

Oopp...sorry about that. Knew I would miss at least one thing off!

Pretty much yes what I was meaning was that I'm just not getting any signal there when I'm using it over a network. I can connect to the RTL-SDR v3 fine with GQRX but lower frequencies just recieve nothing at all.

As an experiment I took a Tecsun AN-200 antenna (it's a MW loop antenna) and connected it to the RTL-SDR stick and then directly connected it to a PC. I did all the required bits and pieces to be brief (rtl=0,direct_samp=2) in GQRX and also made sure "no limits" was enabled. I was able to recieve MW (medium wave) radio relatively well, and I could listen to (I'm from the UK) BBC R5L on 909 and 693 Khz.

If I try to that over a network and with a raspberry pi using rtl_tcp and even if I set -D 2 I get exactly 0% signal, nothing even registers on those frequencies although higher frequencies (such as FM radio) do work. I do have no limits set in GQRX btw (maybe there's something extra I need in rtl_tcp?).

ljones

tim_rtd
Posts: 60
Joined: Fri Jun 30, 2017 11:34 am

Re: RTL-SDR v3 direct sampling over a network

Post by tim_rtd » Sat Oct 13, 2018 4:00 pm

I've duplicated your setup with a Pi and V3 dongle using the rtl_tcp -a xxx xxx xxx xx -D 2. I'm listening to the 20M band at the moment and its working...Using SDR #.... I would say to you from looking a previous post that for some reason your using a very low sampling rate of 204Khz instead of 2.4Mhz....and turn off any freq shift setting. Also I'm using the lan....

ljones
Posts: 4
Joined: Fri Oct 12, 2018 8:19 pm

Re: RTL-SDR v3 direct sampling over a network

Post by ljones » Sat Oct 13, 2018 6:26 pm

only reason I was using a lower sample rate is because I'm using wifi and I found if I used anything much more above than what I chose the audio would break up. Is my sampling rate too low and freq shift setting is there one for rtL_tcp? (If it is the same thing there's a second frequency reading in GQRX which I usually leave on 0 Khz as opposed to the actual freq. just above the waterfall).

Update: I gave using the low sample rate along with using USB direct (as opposed to using wifi). I used these settings with the USB (RTL SDR v3) directly connected into the pc running GQRX:

- device string = rtl=0,direct_samp=2
- input rate=240000

Those should duplicate my raspberry pi/rtl_tcp settings. Tried out normal AM radio and it works but only via a direct USB connection.

Still not working with rtl_tcp though x.x ! Can't help but think maybe either GQRX needs to send *something* to rtl_tcp or maybe a setting in rtl_tcp?

Random thought: prehaps -D 2 in rtl_tcp needs to be specified first? (the way the rtl sdr gets *nothing* on the pi with rtl_tcp makes me think maybe direct sampling isn't working....just a thought).

Here's a couple of pics btw with direct usb connection and via rtl_tcp.

ljones

tim_rtd
Posts: 60
Joined: Fri Jun 30, 2017 11:34 am

Re: RTL-SDR v3 direct sampling over a network

Post by tim_rtd » Sat Oct 13, 2018 9:21 pm

Ok, so I just fired up gqrx on linux box, and after a little searching the web you now use direct_samp=3
Save the config and relaunch. I'm using gqrx 2.11.5
I'm still on the Lan though but at least the see signals...lots of them today for a change....contesting.
Hope this helps......anything other than 3 ...gqrx blows away.
gqrx_direct.png
gqrx_direct.png (505.91 KiB) Viewed 971 times

ljones
Posts: 4
Joined: Fri Oct 12, 2018 8:19 pm

Re: RTL-SDR v3 direct sampling over a network

Post by ljones » Sun Oct 14, 2018 12:14 pm

Aha!

That seemed to do the trick using direct_samp=3 . I now have BBC R5L working over wifi!

For anyone else who is trying to do this FYI:

On the raspberry pi (in /etc/rc.local) add before the "exit 0" line:

Code: Select all

sleep 10
rtl_tcp -a 192.168.0.139 -D 2 -s 215002
And in GQRX v2.11.5 in "Configure I/O devices":
Device=Other
Device String=rtl_tcp=192.168.0.139:1234,direct_samp=3
Input rate=215002
Decimation=None

Note that the "," in the device string 'tween the IP address and direct samp is needed. Omitting the comma would cause GQRX to crash.

Many thanks!

ljones

Post Reply