SBC WIFI not working

Discuss KerberosSDR - 4x Coherent RTL-SDR
mdacosta
Posts: 13
Joined: Mon Mar 18, 2019 6:27 pm

SBC WIFI not working

Post by mdacosta » Mon Mar 18, 2019 6:39 pm

I've followed the Quickstart Guide to install the Tinkerboard Image and it worked. KerberosSDR does run on power up along with VNC. The WIFI shows as Enabled but is not accessible from other devices.

gzcp31
Posts: 6
Joined: Mon Mar 18, 2019 8:22 pm

Re: SBC WIFI not working

Post by gzcp31 » Mon Mar 18, 2019 8:24 pm

I found on the Raspberry PI the Hotspot password was the same as the SSID, not as documented

gzcp31
Posts: 6
Joined: Mon Mar 18, 2019 8:22 pm

Re: SBC WIFI not working

Post by gzcp31 » Mon Mar 18, 2019 9:30 pm

On Tinkerboard, I am having the same issue, WiFi is not accessible from another machine. The Hot spot is not working.

rtlsdrblog
Site Admin
Posts: 2064
Joined: Mon Nov 19, 2012 11:54 pm

Re: SBC WIFI not working

Post by rtlsdrblog » Mon Mar 18, 2019 10:24 pm

Thanks, i've updated the Pi WiFi password on the doc.

On the Tinkerboard, does the WiFi hotspot show up on any device, or not at all? I have it working here with the latest image, just boot and it shows up.

gzcp31
Posts: 6
Joined: Mon Mar 18, 2019 8:22 pm

Re: SBC WIFI not working

Post by gzcp31 » Mon Mar 18, 2019 11:27 pm

I do not show it on any device. I even tried to connect by manually entering the ssid on my Samsung tablet.

Also is there any utility that can be used to verify that the KerberosSDR hardware is talking to the SBC? I have both Tinkerboard and Raspberry and neither are showing any update rate. I even removed one of the dummy loads and installed an antenna with no change.

rtlsdrblog
Site Admin
Posts: 2064
Joined: Mon Nov 19, 2012 11:54 pm

Re: SBC WIFI not working

Post by rtlsdrblog » Mon Mar 18, 2019 11:55 pm

Was the WiFi ever working on your Tinkerboard, with another OS image?

If there is no update rate, then the RTL-SDRs on the board aren't being turned on properly. Did you connect additional power via the USB-C? Check with rtl_test as per the guide too.

gzcp31
Posts: 6
Joined: Mon Mar 18, 2019 8:22 pm

Re: SBC WIFI not working

Post by gzcp31 » Tue Mar 19, 2019 12:26 am

The tinkerboard WiFi works fine with both Android and Linux builds. I am using a USB C for power and the white LED is lighting up. I will try the test program now.

rtlsdrblog
Site Admin
Posts: 2064
Joined: Mon Nov 19, 2012 11:54 pm

Re: SBC WIFI not working

Post by rtlsdrblog » Tue Mar 19, 2019 12:49 am

Oh and double check that all the DIP switches are ON. They should be all ON already by default, but just in case.

gzcp31
Posts: 6
Joined: Mon Mar 18, 2019 8:22 pm

Re: SBC WIFI not working

Post by gzcp31 » Tue Mar 19, 2019 1:36 am

It ended up being a bad micro USB cable. It is now working on the Raspberry build. Thanks for the help I will flash the new Tinkerboard build and give it a try

scoutcamper
Posts: 1
Joined: Tue Mar 19, 2019 1:55 am

Re: SBC WIFI not working

Post by scoutcamper » Tue Mar 19, 2019 2:01 am

The tinkerboard wifi is not working under the kerberos sdr image for me, but under tinkeros wifi works fine, maybe this is a region lock thing?

Specifically I have a Tinkerboard S, it boots into the kerberos sdr image fine, and dmesg shows nothing relevant....

Update: I solved the issue,

To solve the issue do the following:

Code: Select all

vi /etc/NetworkManager/system-connections/Kerberos_Tinker
comment out lines 3 and 9(should be uuid and mac address)

Post Reply