New version of kerberosSDR app

Discuss KerberosSDR - 4x Coherent RTL-SDR
AE6EO
Posts: 2
Joined: Sun Sep 15, 2019 1:57 am

Re: New version of kerberosSDR app

Post by AE6EO » Sun Sep 15, 2019 2:01 am

I was unable to install the app on two of my tablets, which are running an older build of LineageOS. The Play Store app said that they're incompatible with the device.

It installed OK on a Nexus 5X phone, running a more recent revision of LineageOS.

Is there any chance of getting a build which is compatible with older devices (a lower revision of the SDK, I suppose)? These are the sorts of devices I'd probably want to have in the car for signal tracking... less to lose if they're lost/stoken/broken while out foxhunting.

rtlsdrblog
Site Admin
Posts: 2323
Joined: Mon Nov 19, 2012 11:54 pm

Re: New version of kerberosSDR app

Post by rtlsdrblog » Mon Sep 16, 2019 4:22 am

AE6EO wrote:
Sun Sep 15, 2019 2:01 am
I was unable to install the app on two of my tablets, which are running an older build of LineageOS. The Play Store app said that they're incompatible with the device.

It installed OK on a Nexus 5X phone, running a more recent revision of LineageOS.

Is there any chance of getting a build which is compatible with older devices (a lower revision of the SDK, I suppose)? These are the sorts of devices I'd probably want to have in the car for signal tracking... less to lose if they're lost/stoken/broken while out foxhunting.
Next release i'll see if the SDK can be reduced. But i'm not sure if those older devices will even have enough grunt to run the calculations at a reasonable speed.

g4yar
Posts: 7
Joined: Thu Sep 19, 2019 9:52 pm

Re: New version of kerberosSDR app

Post by g4yar » Fri Sep 20, 2019 9:44 am

HI, May I request a new version of the App to work with tablets. I have just purchased the whole system including a new tablet only to find that it's not compatible - rather annoying that I can't use it without purchasing a new phone... (I use Apple normally)

Thanks,
Paul

rtlsdrblog
Site Admin
Posts: 2323
Joined: Mon Nov 19, 2012 11:54 pm

Re: New version of kerberosSDR app

Post by rtlsdrblog » Sat Sep 21, 2019 8:51 am

g4yar wrote:
Fri Sep 20, 2019 9:44 am
HI, May I request a new version of the App to work with tablets. I have just purchased the whole system including a new tablet only to find that it's not compatible - rather annoying that I can't use it without purchasing a new phone... (I use Apple normally)

Thanks,
Paul
Just rolled out a version with a lower SDK target. Can you try and see if it will install now?

myke
Posts: 28
Joined: Wed Aug 28, 2019 7:03 pm

Re: New version of kerberosSDR app

Post by myke » Sat Sep 21, 2019 7:44 pm

I installed it on an Amazon Fire Tablet - it is at Lollipop. I believe that is around Android Version 5.1 ... Of course then I recalled that those tablets rely on WiFi alone for location (no true gps!!) Back to the point.... shows in the play store and installs for earlier version Android - I believe you have success. I will test as soon as I get a charge on an older phone....

rtlsdrblog
Site Admin
Posts: 2323
Joined: Mon Nov 19, 2012 11:54 pm

Re: New version of kerberosSDR app

Post by rtlsdrblog » Sun Sep 22, 2019 2:17 am

myke wrote:
Sat Sep 21, 2019 7:44 pm
I installed it on an Amazon Fire Tablet - it is at Lollipop. I believe that is around Android Version 5.1 ... Of course then I recalled that those tablets rely on WiFi alone for location (no true gps!!) Back to the point.... shows in the play store and installs for earlier version Android - I believe you have success. I will test as soon as I get a charge on an older phone....
Hmm yeah without GPS it would be quite useless. And if you want to use the navigation features, you need something with a 3G/4G internet connection.

ac8dg
Posts: 9
Joined: Fri Jul 19, 2019 12:37 am

Re: New version of kerberosSDR app

Post by ac8dg » Sun Sep 22, 2019 11:08 am

Attempting to use a tablet is becoming very expense and non-workable.

1. My first 10" tablet was android version either 4 or 5, that wouldn't accept the software.
(maybe this latest kerberosdr downgrade will allow it ?)

2. Second 10" tablet had android 7. software loaded, but no gps, wouldn't work

3. Third 10" tablet has android 8 and a gps, but no compass so it doesn't know what is 'up/north'
and no 3g/4g so it can't download map tiles on the go.

So I invested (or wasted) an additional $400 and still don't have a usable system.

rtlsdrblog
Site Admin
Posts: 2323
Joined: Mon Nov 19, 2012 11:54 pm

Re: New version of kerberosSDR app

Post by rtlsdrblog » Mon Sep 23, 2019 3:05 am

ac8dg wrote:
Sun Sep 22, 2019 11:08 am
Attempting to use a tablet is becoming very expense and non-workable.

1. My first 10" tablet was android version either 4 or 5, that wouldn't accept the software.
(maybe this latest kerberosdr downgrade will allow it ?)

2. Second 10" tablet had android 7. software loaded, but no gps, wouldn't work

3. Third 10" tablet has android 8 and a gps, but no compass so it doesn't know what is 'up/north'
and no 3g/4g so it can't download map tiles on the go.

So I invested (or wasted) an additional $400 and still don't have a usable system.
Hmm it would be wise to check the specs of the tablets first before purchasing. Or why not just go with a phone instead?

Duppo
Posts: 16
Joined: Thu Apr 18, 2019 7:10 pm

Re: New version of kerberosSDR app

Post by Duppo » Sat Sep 28, 2019 7:51 pm

Had time this weekend to fire up kerberos.

Decided to use dipole antennas as monopole by removing ground side of dipole and just tilting the remaining antenna to be vertical. Great results!

Located 3 different Tetra transmitters using only the "guided" feature in app. First one that I could drive close by gave me 5 meter accuracy... Crazy!
Second and third I had to pass them 200-500m away and still located within 50-70m accuracy!

Heatmap feature is such a beautiful thing to look at 8-)

AE6EO
Posts: 2
Joined: Sun Sep 15, 2019 1:57 am

Re: New version of kerberosSDR app

Post by AE6EO » Sat Sep 28, 2019 8:36 pm

rtlsdrblog wrote:
Sat Sep 21, 2019 8:51 am
Just rolled out a version with a lower SDK target. Can you try and see if it will install now?
Successfully installed on both a Nexus 7 and a Nexus 10, both running the most-recent LineageOS builds.

Both appear to be working - I haven't yet fired up the server, but the apps show a proper map centered around my current position, download the region map OK, and the UI seems responsive.

Thanks indeed!

Post Reply