How to enable Bias-t for SatNogs station?

Need help installing or figuring out something about your SDR? Ask here.
Post Reply
K3RLD
Posts: 14
Joined: Sun Sep 01, 2019 12:43 am

How to enable Bias-t for SatNogs station?

Post by K3RLD » Sun Sep 01, 2019 12:51 am

Hello, I'm running strictly linux systems.

When I use the

Code: Select all

./rtl_biast -b 1
command to enable the bias-t, it turns on with no problem. However, as soon as I start an application that uses the RTL-SDR.com dongle, it "defaults" the bias-t back to zero.

Now, Alex Csete (GQRX) informed me that using "rtl=0,bias=1" as the device string for GQRX, which does the trick. Does anybody have any idea how to do this with a SatNogs client? I have tried using the "pre-observation script" to turn on the bias-t, but as with GQRX (without the device string modification), it seems as though as soon as the observation starts, the bias-t turns off.

--Roy
K3RLD

rtlsdrblog
Site Admin
Posts: 2273
Joined: Mon Nov 19, 2012 11:54 pm

Re: How to enable Bias-t for SatNogs station?

Post by rtlsdrblog » Sun Sep 01, 2019 4:07 am

The bias tee shouldn't turn off after enabling it, even if you run other software.

But it may be possible though that SatNOGs is using some sort of driver that turns it off. Unfortunately I haven't tested SatNOGS software yet, so I don't know anything about how their software works.

Did you try asking on the SatNOGs forums?

K3RLD
Posts: 14
Joined: Sun Sep 01, 2019 12:43 am

Re: How to enable Bias-t for SatNogs station?

Post by K3RLD » Sun Sep 01, 2019 12:50 pm

Yes, I've got a couple of threads open (my own and a necrothreading of the same phenomena that happened to another ham).

However, regarding "shouldn't turn off after enabling it", this is exactly what happens with GQRX, as well. The only way to get the bias-t to work with it is to put ",bias=1" in the device string. If you simply use the

Code: Select all

rtl_biast -b 1
command the 4.7V DC will drop to zero within a few seconds of launching GQRX.

Alex's response was as follows:
Yeah, this unfortunate topic has been beaten to death over and over again on the gqrx mailing list…

I think the bias tee is switched off when the dongle is re-initialized by another software. Unfortunately, the only way to control the bias-tee in the gr-osmosdr backend is through the device string and that is why there is no easy control for it in gqrx. You can change your device string to:

rtl=0,bias=1

Note that there must be no spaces in the device string.

It is most likely the same issue with SatNOGS as gr-satnogs also uses gr-osmosdr as backend. Not sure where to edit the device string, though…

K3RLD
Posts: 14
Joined: Sun Sep 01, 2019 12:43 am

Re: How to enable Bias-t for SatNogs station?

Post by K3RLD » Thu Sep 05, 2019 3:39 pm

Ok, a suggestion has been made by one of the primary SatNogs contributors.

Essentially, you can add the bias-t switch to the device initiation string by doing the following:

Log into your SatNogs station and initiate satnogs-setup.
Select "Advanced Configuration Options"
Select SATNOGS_DEV_ARGS
Enter the following string:

Code: Select all

rtl,buffers=32,buflen=16384,bias=1
And save. Be sure to use the "apply changes" option before exiting satnogs-setup.

I haven't tried this yet, but will report back with results.

K3RLD
Posts: 14
Joined: Sun Sep 01, 2019 12:43 am

Re: How to enable Bias-t for SatNogs station?

Post by K3RLD » Sat Sep 07, 2019 10:47 pm

Ok, long story short: Still not working.

Another SatNogs user ("danwhite") has done some far more detailed research and come up with the following info:
The current version of GNU Radio that the Ansible scripts install is exactly 0.0.1 point revision older than required to support the bias-T. This is because it depends on a version of gr-osmosdr just before support was added for the feature, which in turn depends on a slightly-too-old version of librtlsdr that exposes the API / ABI for controlling the GPIO pins (which enables the bias-T LDO regulator).

Adding bias=1 to SATNOGS_DEV_ARGS is indeed the correct way to activate the bias-T on that receiver, except that the version is slightly too old wherein the option is ignored. Worse receive performance is then simply because the LNA is not powered at all and attenuating the signal instead :frowning_face:

Pretty much any upgrade to satnogs-client-ansible that bumps the GNU Radio dependency will also cause the bias-T option to work as advertised. Moving the Raspberry Pi image to buster is sufficient for this to happen – a task that is being worked on already most likely. Enabling bias-T use without additional hardware is an important enabler for lowering the expertise required to setup a decent-performance GS.

[edited out station information]

The short term fix is to re-compile the dependency chain of gnuradio <-- gr-osmosdr <-- librtlsdr. I ran out of steam and time before writing down the specific version numbers required for this that are still compatible with the released version of gr-satnogs and plays well with satnogs-client-ansible. If/when I do this, how-to details will get posted in the forums.

K3RLD
Posts: 14
Joined: Sun Sep 01, 2019 12:43 am

Re: How to enable Bias-t for SatNogs station?

Post by K3RLD » Thu Sep 12, 2019 4:22 pm

New update. The latest release of the SatNogs Pi Image (found at the below link) is written for Rasbian Buster and should allow for the usage of the bias-t switch. I won't have time to test until this weekend, but I will report my findings here.

https://gitlab.com/librespacefoundation ... gen/-/tags

K3RLD
Posts: 14
Joined: Sun Sep 01, 2019 12:43 am

Re: How to enable Bias-t for SatNogs station?

Post by K3RLD » Sun Sep 15, 2019 2:15 pm

FInal update. The update to buster-based satnogs pi image has allowed the use of the following arguments to the satnogs-setup parameter of SATNOGS-DEV-ARGS:

Code: Select all

rtl,buffers=32,buflen=16384,bias=1
The only problem is that once the bias-t is on, it will not turn off and stays on indefinately. The solution is to use the RTL-SDR.com bias-t switch found in the https://www.rtl-sdr.com/rtl-sdr-blog-v- ... ser-guide/ as a POST-OBSERVATION-SCRIPT in satnogs-setup. This is my "script":

Code: Select all

/home/pi/rtl_biast/build/src/rtl_biast -b 0
Thus, the bias-t is turned on by the dev args when the sdr is initialized for each observation, and turned off by the post observation script after the satellite pass is completed. Hope this helps others in the future!

Thanks also to RTL-SDR.com blog for the fine products! Almost all SatNogs stations are running on V3 dongles!

--Roy
K3RLD

rtlsdrblog
Site Admin
Posts: 2273
Joined: Mon Nov 19, 2012 11:54 pm

Re: How to enable Bias-t for SatNogs station?

Post by rtlsdrblog » Mon Sep 16, 2019 4:30 am

Excellent, glad to hear that there is a solution (even if it's still a bit clunky).

Post Reply