Can't find RT-SDR source block

Main forum to discuss RTL-SDR related topics.
Post Reply
Posts: 1
Joined: Thu Sep 19, 2019 2:46 pm

Can't find RT-SDR source block

Post by Steven01 » Thu Sep 19, 2019 2:56 pm

Hello everyone,

I have installed GNU Radio and I've been able to play with an Ettus USRP. The UHD: USRP Source and Sink blocks work fine.
But I would like to use a simple RTL2832U dongle, thus I have installed it following these steps:
$ git clone git://
$ cd rtl-sdr/
$ mkdir build
$ cd build
$ cmake ../
$ make
$ sudo make install
$ sudo ldconfig

but I don't find any RTL SDR Source block in GNU Radio... What am I missing? Or has this topic already been dealt with? I am quite new in this SDR world, so thanks in advance for your precious help!

Best regards,

Posts: 138
Joined: Fri Jun 30, 2017 11:34 am

Re: Can't find RT-SDR source block

Post by tim_rtd » Thu Sep 19, 2019 4:32 pm

You want ... I believe...
git clone git://

Posts: 2
Joined: Mon Oct 07, 2019 6:56 am

Re: Can't find RT-SDR source block

Post by bessiethacow » Mon Oct 07, 2019 7:07 am

I believe you also need to enter the command:

sudo apt-get gr-osmosdr

into the terminal. This should install the Osmosdr and the RTL-SDR source and sink blocks to your GNUradio.

This worked for me earlier when I was having this error.

Best Regards,

Posts: 1
Joined: Thu Mar 26, 2020 12:23 am

Re: Can't find RT-SDR source block

Post by LenStruttmann » Thu Mar 26, 2020 12:27 am

It appears that the latest gnuradio (3.8) changed the format of the block definitions from .XML to .YML (YAML). But, it also appears that gr-osmosdr installs the older .XML files into /usr/share/gnuradio/grc/blocks.

A work-around that seems to have worked (so far) is to install the legacy gnuradio (3.7), then gr-osmosdr.

Post Reply