Error When Turning On Bias-T

Need help installing or figuring out something about your SDR? Ask here.
sigol
Posts: 9
Joined: Thu Nov 14, 2019 9:45 pm

Error When Turning On Bias-T

Post by sigol » Thu Nov 14, 2019 9:47 pm

Getting errors when running any of the executables in the bt-driver package (also using Administrator: Command Prompt).

Downloaded SDR# and ran .bat file, which downloaded Zadig and rtlsdr.dll, but I had the dongle USB driver installed manually before that using Zadig 2.4.

S173.png
S173.png (6.53 KiB) Viewed 550 times
S174.png
S174.png (14.14 KiB) Viewed 550 times
S175.png
S175.png (2.13 KiB) Viewed 548 times

sigol
Posts: 9
Joined: Thu Nov 14, 2019 9:45 pm

Re: Error When Turning On Bias-T

Post by sigol » Thu Nov 14, 2019 10:04 pm

S176.png
S176.png (11.07 KiB) Viewed 542 times

rtlsdrblog
Site Admin
Posts: 2421
Joined: Mon Nov 19, 2012 11:54 pm

Re: Error When Turning On Bias-T

Post by rtlsdrblog » Fri Nov 15, 2019 10:56 am

What's your OS? That error is because .NET was not found on your system. Try installing .NET4.0.

sigol
Posts: 9
Joined: Thu Nov 14, 2019 9:45 pm

Re: Error When Turning On Bias-T

Post by sigol » Fri Nov 15, 2019 6:25 pm

Windows 10

Which version exactly because I have 4.8 and software says 4.0 -> Upgraded to 4.8

Will check if older 4.0 can coexist with 4.8

S177.png
S177.png (18.22 KiB) Viewed 495 times

sigol
Posts: 9
Joined: Thu Nov 14, 2019 9:45 pm

Re: Error When Turning On Bias-T

Post by sigol » Fri Nov 15, 2019 6:31 pm

Downloaded .NET 4.0 standalone installer, but when I tried running it, got the message:

"1. Microsoft .NET Framework 4 is already a part of this operating system. You do not need to install the .NET Framework 4 redistributable."

S178.png
S178.png (8.58 KiB) Viewed 493 times

rtlsdrblog
Site Admin
Posts: 2421
Joined: Mon Nov 19, 2012 11:54 pm

Re: Error When Turning On Bias-T

Post by rtlsdrblog » Sat Nov 16, 2019 7:52 am

Hmm it could also be that your Visual C++ redistributal somehow got corrupted.

Can you try reinstalling it via the links here? Choose the exe for 2015,107,2019.

https://support.microsoft.com/en-us/hel ... -downloads

sigol
Posts: 9
Joined: Thu Nov 14, 2019 9:45 pm

Re: Error When Turning On Bias-T

Post by sigol » Sat Nov 16, 2019 3:29 pm

Downloaded x86 & x64 versions from link posted above, installed them, and restarted.

Still getting error message.

Windows 1903

S179.png
S179.png (16.01 KiB) Viewed 417 times

rtlsdrblog
Site Admin
Posts: 2421
Joined: Mon Nov 19, 2012 11:54 pm

Re: Error When Turning On Bias-T

Post by rtlsdrblog » Mon Nov 18, 2019 2:24 am

Bizarre, i'm not too sure then. It definitely works on other Win10 machines.

Can you try this version https://github.com/rtlsdrblog/rtl-sdr-blog/releases

sigol
Posts: 9
Joined: Thu Nov 14, 2019 9:45 pm

Re: Error When Turning On Bias-T

Post by sigol » Mon Nov 18, 2019 5:55 pm

Same error. Tried moving the folder to another partition, no change.

I can run the executables from OSMOCOM and the dongle is working, but these files don't include a rtl_biast.exe.

S187.png
S187.png (18.4 KiB) Viewed 278 times
S188.png
S188.png (2.63 KiB) Viewed 276 times

sigol
Posts: 9
Joined: Thu Nov 14, 2019 9:45 pm

Re: Error When Turning On Bias-T

Post by sigol » Mon Nov 18, 2019 6:09 pm

Tried running compatibility troubleshooting on rtl_biast.exe and got a restriction error.

I installed OS from scratch and I'm using an administrator account.

If I must take ownership, then ownership of what?

I'm not using the new features from 1903 like the ransomware protection, only the basic Windows Defender with firewall, but no SmartScreen or Check apps and files.

S189.png
S189.png (5.89 KiB) Viewed 276 times
S190.png
S190.png (7.85 KiB) Viewed 275 times
The attachment S191.png is no longer available
Attachments
S191.png
S191.png (6.93 KiB) Viewed 275 times

Post Reply