windows 10 not run SDR

Need help installing or figuring out something about your SDR? Ask here.
Post Reply
Ron Roberts
Posts: 1
Joined: Sat Jan 16, 2021 11:29 pm

windows 10 not run SDR

Post by Ron Roberts » Sun Jan 17, 2021 12:32 am

Hi all, I’m new to this forum,

looking for help on my RTL.SDR USB, my windows 10 computer will not run it, I've been trying now for weeks and i really mean weeks daily.

got so fed up with it, thinking i was setting it up wrong saying it has to be me, but i know it wasn't read everything trying to get this sorted.

So I'm on,
Windows 10 64bit
Software is HDSDR and SDRSharp,
I've down loaded Zadig 2.5 and run it correctly. ill explain how i know in a minute.
I've also placed the correct ExtIO_RTL2832.dll in the main folder of HDSDR also ran the bat file under SDRSharp.
Now the HDSDR software and SDRSharp run somewhat but the HDSDR runs the best and that's the one i like, for from now on i will be only referring to HDSDR only.

I've reinstalled uninstalled tried every USB port all 12 of them, and i get the same result,
no device found i have 3 diffract ExtIO files in the folder so it asks witch to run i can select any of the and i get the same.
its has the SDR is not plugged in, i know all my USB ports are ok as i use them daily and never had a problem till now.

in my frustration i set up a windows 7 computer out of all the bits i have knocking around, its only a 32bit system as it that old, set up the software and STL.SDR and Zadig 2.3 as its a 32bit system and Zadig 2.5 wont run one 32bit. loaded the HDSDR software and boom worked first time.

The CPU isn't up to the job of running the SDR and he keeps hanging the software but working, proving I'm installing things correctly, the SDR is working just fine.

Now all the HDSDR software on the windows 10 is running sometimes it looks like its running, the waterfall showing what appears to be singles went trying to tune through frequencies and bands, it makes all wish and woo sounds and noises
like its working but its not, as its using my computers microphone somehow when I remove this microphone and try to run the HDSDR I get now input sound card available, now I got to the options and select input and click on the Extlo, to run the file and some times I get RTL device was found but coult not open. Used by another application or Zadig not installed. That’s letter for letter.

any help please, I've tried to ask for help on other forums and all one gets is reinstall the Zadig, I've do that as to me 30 times or more, downloads from sources as well its 100 present not that, I've even uninstall the drivers from within file manager and reinstalled, got the latest USB drives installed and changed them back and so on. I've almost removed everything and uninstalled everything from the windows 10 computer just to see nothing works,

I've had it running on a old windows vista computer as well but wont run on windows 10 computer.

Any help please,

rtlsdrblog
Site Admin
Posts: 2835
Joined: Mon Nov 19, 2012 11:54 pm

Re: windows 10 not run SDR

Post by rtlsdrblog » Wed Jan 20, 2021 5:26 am

Sounds like your HDSDR is actually connected to the PCs soundcard and not the RTL-SDR.

When you try to run it in SDR#, could you please post the *exact* error that you get? Ideally in a screenshot. Also a screenshot of your zadig screen helps.

Post Reply