RTL issues with AMD Ryzen, Windows 10 x64

Main forum to discuss RTL-SDR related topics.
Post Reply
w2lie
Posts: 1
Joined: Sun Feb 21, 2021 2:57 pm

RTL issues with AMD Ryzen, Windows 10 x64

Post by w2lie » Sun Feb 21, 2021 3:14 pm

HI All

I'm running into a huge problem that I've been trying to find a solution to for the entire day.

If you don't feel like reading, this video describes my issues



My issue is similar to this one, but yet not exactly the same. I also tried the DLL files in this link but that did not help my situation.


I just built a new computer to run some SDR projects. This PC was built for this and I think Murphy has his hands in this build.
AMD Ryzen 3700X at 3.60Ghz, 32GB RAM, Windows 10 Home 64Bit, and Radeon RX 5500 XT display adapter.
PC was built primarily to run many different SDR applications and hardware. I haven't had any problems like this on any other computer until now. (go figure)

I'm running NooElec, RTL-Blog V3, and AirSpy hardware as well as SDR# and SDR-Console.
I'm only using 1 piece of hardware at a time to troubleshoot. I've tried several USB ports on my computer and all ports are directly connected to the motherboard's header pins. I'm not using any USB hubs or expansion cards. I've tried both 2.0 and 3.0 ports on my computer.


The problem does not appear on my laptop with the same hardware/software and is not present when I use the AirSpy on the new desktop.
This only happens with the NooElec or RTL-SDR v3 devices with both SDR# and with SDR-Console.


Issue 1. SDR# will crash if I start, stop, and then attempt to restart the receiver. I am able to start the receiver and tune. However, once the receiver is stopped, it will not restart. SDR# crashes.

Issue 2. SDR# and SDR-Console will begin to receive "off frequency". I begin on frequency with FM Broadcast Radio. Eventually while moving down the dial, the frequency will continue to move down, but the actual received frequency will just keep repeating. It never moves down to match the displayed frequency

Issue 3. Same as above with SDR# and SDR-Console will begin to receive "off frequency". So instead of showing say 94.3, the center frequency is 94.4MHz (which we don't use here in the US). The actual received frequency is about 1.5Mhz off from where things look on the display. Moving the dial in the opposite direction corrects the display and received frequency.


I'm running SDR# 1.0.0.1803 (did not have the computer built to try any other previous versions). I did install .NET 5 x86 per instructions on the Airspy website.
Zadig has WinUSB V6.1.7600.16385 installed for the NooElec and v3 SDR's, with the exception of the AirSpy.


Is this just another AMD Ryzen issue?

Besides testing the NooElec and RTL-SDRv3 on SDR# and Console, I have not yet tried these cards with software like UniTrunker, DSD Plus, etc. If these sticks work fine on this type of software, then I will breath a sigh of relief.

At this point, I'm trying to understand why this same hardware and software will work fine on other computers but gives this purpose built desktop so much trouble. I've been using RTL style dongles for years. This is not my first install.

I also have a RSPdx and Hack RF, but I have not tested those on this machine yet. I expect them to work since the Airspy worked directly out of the box and does not exhibit the same issues as the cheaper USB sticks.


Thanks in advance for any help you can provide.

73
Phil / w2lie

VE1KK
Posts: 1
Joined: Tue Feb 23, 2021 11:47 pm

Re: RTL issues with AMD Ryzen, Windows 10 x64

Post by VE1KK » Wed Feb 24, 2021 12:47 am

Hello,

I am new to SDR's but ran across this thread while trying to troubleshoot the issue of SDR# crashing when you start, stop, then try to restart the receiver. Event Viewer indicates the crash is related to .NET, specifically CORECLR.DLL, v 5.02.

System: 10-year-old PC, Win10 x64, SDR#1801
RTLSDR: Nooelec SMArt V4

Troubleshooting:

I actually started with earlier versions of SDR# - all exhibited this same issue.

I installed whatever Windows Update offered, including a driver for the SDR. Nothing helped and the driver changed the SDR from a USB Device to a Sound, Video and Game Controller and SDR# could no longer see it. I had to roll back the driver.

I installed .NET 5.03 but SDR# continued calling .NET 5.02...and crashing.

I also have DSD+ installed which works fine. I started looking at RTLSDR.DLL - both had v 1.0.0.1 but they were different sizes - 44,032 bytes in SDR# and 46,080 bytes in DSD+!

I copied RTLSDR.DLL from DSD+ to SDR# and it solved the problem - I can now start/stop/restart the receiver without a crash! Who knows why?

SDR# is also doing a better job of remembering settings, which makes sense since it's now closing properly instead of crashing.

As an SDR newbie I can't comment on the other issues.

Hope this helps.

Kevin, VE1KK

rtlsdrblog
Site Admin
Posts: 2870
Joined: Mon Nov 19, 2012 11:54 pm

Re: RTL issues with AMD Ryzen, Windows 10 x64

Post by rtlsdrblog » Fri Mar 05, 2021 4:53 am

If one of you have time, could you please also check if our modded drivers work properly? Ryzen is a bit tricky with a lot of bugs with USB.

https://github.com/rtlsdrblog/rtl-sdr-b ... s/tag/1.01

Post Reply